p PatchFirst

CVE-2017-12618

CVE-2017-12618

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Apache Portable Runtime Utility (APR-util) 1.6.0 and prior fail to validate the integrity of SDBM database files used by apr_sdbm*() functions, resulting in a possible out of bound read access. A local user with write access to the database can make a program or process using these functions crash, and cause a denial of service.

CVSS 4.7 · Medium · EPSS 0.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache portable runtime

    Versions
    • 1.6.0 and prior: Affected

    No fix published

  • apr-util Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.6.1-1

    Update to 1.6.1-1

  • apr-util Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.6.1-1

    Update to 1.6.1-1

  • apr-util Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.6.1-1

    Update to 1.6.1-1

  • apr-util Ubuntu:Pro:14.04:LTS

    Versions
    • 1.5.2-1
    • 1.5.2-1build1
    • 1.5.2-2ubuntu1
    • 1.5.3-1
    Affected ranges
    • ECOSYSTEM: < 1.5.3-1ubuntu0.1~esm1

    Update to 1.5.3-1ubuntu0.1~esm1

  • apr-util Ubuntu:Pro:16.04:LTS

    Versions
    • 1.5.4-1
    • 1.5.4-1build1
    Affected ranges
    • ECOSYSTEM: < 1.5.4-1ubuntu0.1~esm1

    Update to 1.5.4-1ubuntu0.1~esm1

Original sources

Check your server →