p PatchFirst

PatchFirst · Latest vulnerabilities

apr-util vulnerabilities

Vulnerabilities published for apr-util in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2022-25147

    Medium · CVSS 6.5EPSS 1.43%Fix available

    Apache Portable Runtime Utility (APR-util): out-of-bounds writes in the apr_base64 family of functions

    Integer Overflow or Wraparound vulnerability in apr_base64 functions of Apache Portable Runtime Utility (APR-util) allows an attacker to write beyond bounds of a buffer. This issue affects Apache Portable Runtime Utility (APR-util) 1.6.1 and prior versions.

    • Update to 1.5.4-1ubuntu0.1~esm2
    Published Updated
  2. CVE-2017-12618

    Medium · CVSS 4.7EPSS 0.6%Fix available

    CVE-2017-12618

    Apache Portable Runtime Utility (APR-util) 1.6.0 and prior fail to validate the integrity of SDBM database files used by apr_sdbm*() functions, resulting in a possible out of bound read access. A local user with write access to the database can make a program or process using these functions crash, and cause a denial of service.

    • Update to 1.5.4-1ubuntu0.1~esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →