CVE-2017-14033
CVE-2017-14033
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string.
CVSS 7.5 · High · EPSS 7.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ruby1.9.1 Ubuntu:14.04:LTS
- Versions
- 1.9.3.194-8.1ubuntu2
- 1.9.3.448-1ubuntu1
- 1.9.3.448-1ubuntu2
- 1.9.3.484-1ubuntu1
- 1.9.3.484-1ubuntu2
- 1.9.3.484-2ubuntu1
- 1.9.3.484-2ubuntu1.1
- 1.9.3.484-2ubuntu1.2
- 1.9.3.484-2ubuntu1.3
- Affected ranges
- ECOSYSTEM: < 1.9.3.484-2ubuntu1.5
Update to 1.9.3.484-2ubuntu1.5
ruby2.3 Ubuntu:16.04:LTS
- Versions
- 2.3.0-1
- 2.3.0-2
- 2.3.0-4ubuntu2
- 2.3.0-4ubuntu3
- 2.3.0-5ubuntu1
- 2.3.1-2~16.04
- 2.3.1-2~16.04.2
- 2.3.1-2~16.04.4
- Affected ranges
- ECOSYSTEM: < 2.3.1-2~16.04.5
Update to 2.3.1-2~16.04.5
Original sources
- https://access.redhat.com/errata/RHSA-2018:0585
- https://www.ruby-lang.org/en/news/2017/09/14/ruby-2-3-5-released/
- https://access.redhat.com/errata/RHSA-2018:0378
- http://www.securitytracker.com/id/1042004
- https://www.debian.org/security/2017/dsa-4031
- https://www.ruby-lang.org/en/news/2017/09/14/ruby-2-2-8-released/
- http://www.securitytracker.com/id/1039363
- https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- https://access.redhat.com/errata/RHSA-2018:0583
- https://www.ruby-lang.org/en/news/2017/09/14/openssl-asn1-buffer-underrun-cve-2017-14033/
- http://www.securityfocus.com/bid/100868
- https://security.gentoo.org/glsa/201710-18
- https://nvd.nist.gov/vuln/detail/CVE-2017-14033