CVE-2017-14976
CVE-2017-14976
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The FoFiType1C::convertToType0 function in FoFiType1C.cc in Poppler 0.59.0 has a heap-based buffer over-read vulnerability if an out-of-bounds font dictionary index is encountered, which allows an attacker to launch a denial of service attack.
CVSS 7.5 · High · EPSS 2.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
poppler Debian:12
- Affected ranges
- ECOSYSTEM: < 0.61.1-2
Update to 0.61.1-2
poppler Debian:13
- Affected ranges
- ECOSYSTEM: < 0.61.1-2
Update to 0.61.1-2
poppler Debian:14
- Affected ranges
- ECOSYSTEM: < 0.61.1-2
Update to 0.61.1-2
poppler Ubuntu:14.04:LTS
- Versions
- 0.24.1-0ubuntu1
- 0.24.3-0ubuntu1
- 0.24.3-0ubuntu2
- 0.24.3-0ubuntu3
- 0.24.3-0ubuntu4
- 0.24.3-0ubuntu5
- 0.24.3-0ubuntu6
- 0.24.3-0ubuntu7
- 0.24.3-0ubuntu8
- 0.24.3-0ubuntu10
- 0.24.3-0ubuntu12
- 0.24.5-0ubuntu3
- 0.24.5-2ubuntu1
- 0.24.5-2ubuntu2
- 0.24.5-2ubuntu4
- 0.24.5-2ubuntu4.1
- 0.24.5-2ubuntu4.2
- 0.24.5-2ubuntu4.3
- 0.24.5-2ubuntu4.4
- 0.24.5-2ubuntu4.5
- 0.24.5-2ubuntu4.6
- 0.24.5-2ubuntu4.7
- 0.24.5-2ubuntu4.8
- Affected ranges
- ECOSYSTEM: < 0.24.5-2ubuntu4.9
Update to 0.24.5-2ubuntu4.9
poppler Ubuntu:16.04:LTS
- Versions
- 0.33.0-0ubuntu3
- 0.37.0-0ubuntu1
- 0.38.0-0ubuntu1
- 0.41.0-0ubuntu1
- 0.41.0-0ubuntu1.1
- 0.41.0-0ubuntu1.2
- 0.41.0-0ubuntu1.3
- 0.41.0-0ubuntu1.4
- 0.41.0-0ubuntu1.5
- Affected ranges
- ECOSYSTEM: < 0.41.0-0ubuntu1.6
Update to 0.41.0-0ubuntu1.6
Original sources
- https://cgit.freedesktop.org/poppler/poppler/commit/?id=da63c35549e8852a410946ab016a3f25ac701bdf
- https://www.debian.org/security/2018/dsa-4079
- https://bugzilla.freedesktop.org/show_bug.cgi?id=102724
- https://lists.debian.org/debian-lts-announce/2017/11/msg00023.html
- https://nvd.nist.gov/vuln/detail/CVE-2017-14976