CVE-2017-18267
CVE-2017-18267
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The FoFiType1C::cvtGlyph function in fofi/FoFiType1C.cc in Poppler through 0.64.0 allows remote attackers to cause a denial of service (infinite recursion) via a crafted PDF file, as demonstrated by pdftops.
CVSS 5.5 · Medium · EPSS 1.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
poppler Debian:12
- Affected ranges
- ECOSYSTEM: < 0.69.0-2
Update to 0.69.0-2
poppler Debian:13
- Affected ranges
- ECOSYSTEM: < 0.69.0-2
Update to 0.69.0-2
poppler Debian:14
- Affected ranges
- ECOSYSTEM: < 0.69.0-2
Update to 0.69.0-2
poppler Ubuntu:14.04:LTS
- Versions
- 0.24.1-0ubuntu1
- 0.24.3-0ubuntu1
- 0.24.3-0ubuntu2
- 0.24.3-0ubuntu3
- 0.24.3-0ubuntu4
- 0.24.3-0ubuntu5
- 0.24.3-0ubuntu6
- 0.24.3-0ubuntu7
- 0.24.3-0ubuntu8
- 0.24.3-0ubuntu10
- 0.24.3-0ubuntu12
- 0.24.5-0ubuntu3
- 0.24.5-2ubuntu1
- 0.24.5-2ubuntu2
- 0.24.5-2ubuntu4
- 0.24.5-2ubuntu4.1
- 0.24.5-2ubuntu4.2
- 0.24.5-2ubuntu4.3
- 0.24.5-2ubuntu4.4
- 0.24.5-2ubuntu4.5
- 0.24.5-2ubuntu4.6
- 0.24.5-2ubuntu4.7
- 0.24.5-2ubuntu4.8
- 0.24.5-2ubuntu4.9
- Affected ranges
- ECOSYSTEM: < 0.24.5-2ubuntu4.11
Update to 0.24.5-2ubuntu4.11
poppler Ubuntu:16.04:LTS
- Versions
- 0.33.0-0ubuntu3
- 0.37.0-0ubuntu1
- 0.38.0-0ubuntu1
- 0.41.0-0ubuntu1
- 0.41.0-0ubuntu1.1
- 0.41.0-0ubuntu1.2
- 0.41.0-0ubuntu1.3
- 0.41.0-0ubuntu1.4
- 0.41.0-0ubuntu1.5
- 0.41.0-0ubuntu1.6
- Affected ranges
- ECOSYSTEM: < 0.41.0-0ubuntu1.7
Update to 0.41.0-0ubuntu1.7
poppler Ubuntu:18.04:LTS
- Versions
- 0.57.0-2ubuntu4
- 0.57.0-2ubuntu5
- 0.62.0-1ubuntu1
- 0.62.0-2ubuntu1
- 0.62.0-2ubuntu2
- Affected ranges
- ECOSYSTEM: < 0.62.0-2ubuntu2.1
Update to 0.62.0-2ubuntu2.1
Original sources
- https://bugzilla.freedesktop.org/show_bug.cgi?id=103238
- https://lists.debian.org/debian-lts-announce/2018/10/msg00024.html
- https://access.redhat.com/errata/RHSA-2018:3505
- https://usn.ubuntu.com/3647-1/
- https://access.redhat.com/errata/RHSA-2018:3140
- https://access.redhat.com/errata/RHBA-2019:0327
- https://lists.debian.org/debian-lts-announce/2020/07/msg00018.html
- https://nvd.nist.gov/vuln/detail/CVE-2017-18267