CVE-2017-2820
CVE-2017-2820
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An exploitable integer overflow vulnerability exists in the JPEG 2000 image parsing functionality of freedesktop.org Poppler 0.53.0. A specially crafted PDF file can lead to an integer overflow causing out of bounds memory overwrite on the heap resulting in potential arbitrary code execution. To trigger this vulnerability, a victim must open the malicious PDF in an application using this library.
CVSS 8.8 · High · EPSS 4.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
poppler
- Versions
- 0.53: Affected
No fix published
poppler Debian:12
- Versions
- 22.12.0-2
- 22.12.0-2+deb12u1
- 22.12.0-2+deb12u2
- 22.12.0-2+deb12u3
- 22.12.0-2.1
- 22.12.0-2.2
- 23.08.0-1
- 23.08.0-2
- 23.12.0-1
- 24.02.0-1
- 24.02.0-2
- 24.02.0-3
- 24.02.0-4
- 24.02.0-5
- 24.02.0-5+loong64
- 24.06.0-1
- 24.06.0-2
- 24.08.0-1
- 24.08.0-2
- 24.08.0-3
- 24.08.0-4
- 25.01.0-1
- 25.01.0-2
- 25.01.0-3
- 25.01.0-4
- 25.01.0-5
- 25.03.0-1
- 25.03.0-10
- 25.03.0-11
- 25.03.0-11.1
- 25.03.0-2
- 25.03.0-3
- 25.03.0-4
- 25.03.0-5
- 25.03.0-6
- 25.03.0-7
- 25.03.0-9
- 26.01.0-1
- 26.01.0-2
- 26.01.0-3
- 26.01.0-4
- 26.01.0-4.1
- 26.01.0-5
- 26.07.0-1
- 26.07.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
poppler Debian:13
- Versions
- 25.03.0-10
- 25.03.0-11
- 25.03.0-11.1
- 25.03.0-5
- 25.03.0-5+deb13u2
- 25.03.0-5+deb13u3
- 25.03.0-5+deb13u4
- 25.03.0-6
- 25.03.0-7
- 25.03.0-9
- 26.01.0-1
- 26.01.0-2
- 26.01.0-3
- 26.01.0-4
- 26.01.0-4.1
- 26.01.0-5
- 26.07.0-1
- 26.07.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
poppler Debian:14
- Versions
- 25.03.0-10
- 25.03.0-11
- 25.03.0-11.1
- 25.03.0-5
- 25.03.0-6
- 25.03.0-7
- 25.03.0-9
- 26.01.0-1
- 26.01.0-2
- 26.01.0-3
- 26.01.0-4
- 26.01.0-4.1
- 26.01.0-5
- 26.07.0-1
- 26.07.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
poppler Ubuntu:14.04:LTS
- Versions
- 0.24.1-0ubuntu1
- 0.24.3-0ubuntu1
- 0.24.3-0ubuntu2
- 0.24.3-0ubuntu3
- 0.24.3-0ubuntu4
- 0.24.3-0ubuntu5
- 0.24.3-0ubuntu6
- 0.24.3-0ubuntu7
- 0.24.3-0ubuntu8
- 0.24.3-0ubuntu10
- 0.24.3-0ubuntu12
- 0.24.5-0ubuntu3
- 0.24.5-2ubuntu1
- 0.24.5-2ubuntu2
- 0.24.5-2ubuntu4
- 0.24.5-2ubuntu4.1
- 0.24.5-2ubuntu4.2
- 0.24.5-2ubuntu4.3
- 0.24.5-2ubuntu4.4
- Affected ranges
- ECOSYSTEM: < 0.24.5-2ubuntu4.5
Update to 0.24.5-2ubuntu4.5
poppler Ubuntu:16.04:LTS
- Versions
- 0.33.0-0ubuntu3
- 0.37.0-0ubuntu1
- 0.38.0-0ubuntu1
- 0.41.0-0ubuntu1
- 0.41.0-0ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 0.41.0-0ubuntu1.2
Update to 0.41.0-0ubuntu1.2