p PatchFirst

CVE-2017-7506

CVE-2017-7506

This page contains facts from public vulnerability sources. Check the original advisory before updating.

spice versions though 0.13 are vulnerable to out-of-bounds memory access when processing specially crafted messages from authenticated attacker to the spice server resulting into crash and/or server memory leak.

CVSS 8.8 · High · EPSS 4.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • spice

    Versions
    • all versions through 0.13: Affected

    No fix published

  • spice Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.12.8-2.2

    Update to 0.12.8-2.2

  • spice Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.12.8-2.2

    Update to 0.12.8-2.2

  • spice Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.12.8-2.2

    Update to 0.12.8-2.2

  • spice Ubuntu:14.04:LTS

    Versions
    • 0.12.4-0nocelt1
    • 0.12.4-0nocelt1.1
    • 0.12.4-0nocelt1.1ubuntu1
    • 0.12.4-0nocelt2
    • 0.12.4-0nocelt2ubuntu1
    • 0.12.4-0nocelt2ubuntu1.1
    • 0.12.4-0nocelt2ubuntu1.2
    • 0.12.4-0nocelt2ubuntu1.3
    • 0.12.4-0nocelt2ubuntu1.4
    Affected ranges
    • ECOSYSTEM: < 0.12.4-0nocelt2ubuntu1.5

    Update to 0.12.4-0nocelt2ubuntu1.5

  • spice Ubuntu:16.04:LTS

    Versions
    • 0.12.5-1.1ubuntu2
    • 0.12.6-4
    • 0.12.6-4ubuntu0.1
    • 0.12.6-4ubuntu0.2
    Affected ranges
    • ECOSYSTEM: < 0.12.6-4ubuntu0.3

    Update to 0.12.6-4ubuntu0.3

Original sources

Check your server →