p PatchFirst

CVE-2018-1000078

CVE-2018-1000078

This page contains facts from public vulnerability sources. Check the original advisory before updating.

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack appear to be exploitable via the victim must browse to a malicious gem on a vulnerable gem server. This vulnerability appears to have been fixed in 2.7.6.

CVSS 6.1 · Medium · EPSS 2.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • jruby Debian:12

    Affected ranges
    • ECOSYSTEM: < 9.1.17.0-1

    Update to 9.1.17.0-1

  • jruby Debian:13

    Affected ranges
    • ECOSYSTEM: < 9.1.17.0-1

    Update to 9.1.17.0-1

  • jruby Debian:14

    Affected ranges
    • ECOSYSTEM: < 9.1.17.0-1

    Update to 9.1.17.0-1

  • rubygems Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Update to 3.2.0~rc.1-1

  • rubygems Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Update to 3.2.0~rc.1-1

  • rubygems Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Update to 3.2.0~rc.1-1

  • ruby1.9.1 Ubuntu:14.04:LTS

    Versions
    • 1.9.3.194-8.1ubuntu2
    • 1.9.3.448-1ubuntu1
    • 1.9.3.448-1ubuntu2
    • 1.9.3.484-1ubuntu1
    • 1.9.3.484-1ubuntu2
    • 1.9.3.484-2ubuntu1
    • 1.9.3.484-2ubuntu1.1
    • 1.9.3.484-2ubuntu1.2
    • 1.9.3.484-2ubuntu1.3
    • 1.9.3.484-2ubuntu1.5
    • 1.9.3.484-2ubuntu1.6
    • 1.9.3.484-2ubuntu1.7
    Affected ranges
    • ECOSYSTEM: < 1.9.3.484-2ubuntu1.8

    Update to 1.9.3.484-2ubuntu1.8

  • ruby2.0 Ubuntu:14.04:LTS

    Versions
    • 2.0.0.299-2
    • 2.0.0.343-1
    • 2.0.0.343-1ubuntu1
    • 2.0.0.353-1
    • 2.0.0.353-1ubuntu1
    • 2.0.0.484-1ubuntu1
    • 2.0.0.484-1ubuntu2
    • 2.0.0.484-1ubuntu2.1
    • 2.0.0.484-1ubuntu2.2
    • 2.0.0.484-1ubuntu2.4
    • 2.0.0.484-1ubuntu2.5
    Affected ranges
    • ECOSYSTEM: < 2.0.0.484-1ubuntu2.6

    Update to 2.0.0.484-1ubuntu2.6

  • jruby Ubuntu:Pro:14.04:LTS

    Versions
    • 1.5.6-5ubuntu1
    • 1.5.6-6
    • 1.5.6-7
    Affected ranges
    • ECOSYSTEM: < 1.5.6-9+deb8u2build0.14.04.1~esm2

    Update to 1.5.6-9+deb8u2build0.14.04.1~esm2

  • ruby2.3 Ubuntu:16.04:LTS

    Versions
    • 2.3.0-1
    • 2.3.0-2
    • 2.3.0-4ubuntu2
    • 2.3.0-4ubuntu3
    • 2.3.0-5ubuntu1
    • 2.3.1-2~16.04
    • 2.3.1-2~16.04.2
    • 2.3.1-2~16.04.4
    • 2.3.1-2~16.04.5
    • 2.3.1-2~16.04.6
    Affected ranges
    • ECOSYSTEM: < 2.3.1-2~16.04.7

    Update to 2.3.1-2~16.04.7

  • jruby Ubuntu:16.04:LTS

    Versions
    • 1.7.21-2ubuntu4
    • 1.7.22-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • jruby Ubuntu:18.04:LTS

    Versions
    • 9.1.13.0-1
    • 9.1.17.0-1~18.04
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →