CVE-2018-10194
CVE-2018-10194
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The set_text_distance function in devices/vector/gdevpdts.c in the pdfwrite component in Artifex Ghostscript through 9.22 does not prevent overflows in text-positioning calculation, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted PDF document.
CVSS 7.8 · High · EPSS 2.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ghostscript Debian:12
- Affected ranges
- ECOSYSTEM: < 9.22~dfsg-2.1
Update to 9.22~dfsg-2.1
ghostscript Debian:13
- Affected ranges
- ECOSYSTEM: < 9.22~dfsg-2.1
Update to 9.22~dfsg-2.1
ghostscript Debian:14
- Affected ranges
- ECOSYSTEM: < 9.22~dfsg-2.1
Update to 9.22~dfsg-2.1
ghostscript Ubuntu:14.04:LTS
- Versions
- 9.10~dfsg-0ubuntu2
- 9.10~dfsg-0ubuntu3
- 9.10~dfsg-0ubuntu4
- 9.10~dfsg-0ubuntu5
- 9.10~dfsg-0ubuntu6
- 9.10~dfsg-0ubuntu7
- 9.10~dfsg-0ubuntu8
- 9.10~dfsg-0ubuntu9
- 9.10~dfsg-0ubuntu10
- 9.10~dfsg-0ubuntu10.1
- 9.10~dfsg-0ubuntu10.2
- 9.10~dfsg-0ubuntu10.3
- 9.10~dfsg-0ubuntu10.4
- 9.10~dfsg-0ubuntu10.5
- 9.10~dfsg-0ubuntu10.6
- 9.10~dfsg-0ubuntu10.7
- 9.10~dfsg-0ubuntu10.9
- 9.10~dfsg-0ubuntu10.10
- Affected ranges
- ECOSYSTEM: < 9.10~dfsg-0ubuntu10.12
Update to 9.10~dfsg-0ubuntu10.12
ghostscript Ubuntu:16.04:LTS
- Versions
- 9.16~dfsg~0-0ubuntu3
- 9.16~dfsg~0-0ubuntu4
- 9.18~dfsg~0-0ubuntu1
- 9.18~dfsg~0-0ubuntu2
- 9.18~dfsg~0-0ubuntu2.2
- 9.18~dfsg~0-0ubuntu2.3
- 9.18~dfsg~0-0ubuntu2.4
- 9.18~dfsg~0-0ubuntu2.6
- 9.18~dfsg~0-0ubuntu2.7
- Affected ranges
- ECOSYSTEM: < 9.18~dfsg~0-0ubuntu2.8
Update to 9.18~dfsg~0-0ubuntu2.8
ghostscript Ubuntu:18.04:LTS
- Versions
- 9.21~dfsg+1-0ubuntu3
- 9.22~dfsg+1-0ubuntu1
- Affected ranges
- ECOSYSTEM: < 9.22~dfsg+1-0ubuntu1.1
Update to 9.22~dfsg+1-0ubuntu1.1
Original sources
- https://access.redhat.com/errata/RHSA-2018:2918
- https://security.gentoo.org/glsa/201811-12
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=39b1e54b2968620723bf32e96764c88797714879
- https://lists.debian.org/debian-lts-announce/2018/04/msg00028.html
- https://usn.ubuntu.com/3636-1/
- https://bugs.ghostscript.com/show_bug.cgi?id=699255
- http://www.securitytracker.com/id/1040729
- https://nvd.nist.gov/vuln/detail/CVE-2018-10194