p PatchFirst

CVE-2018-10900

CVE-2018-10900

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.

CVSS 8.8 · High · EPSS 3.9% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • networkmanager-vpnc

    Versions
    • NetworkManager-vpnc 1.2.6: Affected

    No fix published

  • network-manager-vpnc Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.2.6-1

    Update to 1.2.6-1

  • network-manager-vpnc Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.2.6-1

    Update to 1.2.6-1

  • network-manager-vpnc Ubuntu:14.04:LTS

    Versions
    • 0.9.8.2-1ubuntu1
    • 0.9.8.6-1ubuntu1
    • 0.9.8.6-1ubuntu2
    Affected ranges
    • ECOSYSTEM: < 0.9.8.6-1ubuntu2.1

    Update to 0.9.8.6-1ubuntu2.1

  • network-manager-vpnc Ubuntu:16.04:LTS

    Versions
    • 0.9.10.0-1ubuntu1
    • 1.0.8-1ubuntu1
    • 1.1.93-1
    Affected ranges
    • ECOSYSTEM: < 1.1.93-1ubuntu0.1

    Update to 1.1.93-1ubuntu0.1

  • network-manager-vpnc Ubuntu:18.04:LTS

    Versions
    • 1.2.4-4
    • 1.2.4-6
    Affected ranges
    • ECOSYSTEM: < 1.2.4-6ubuntu0.1

    Update to 1.2.4-6ubuntu0.1

Original sources

Check your server →