p PatchFirst

PatchFirst · Latest vulnerabilities

network-manager-vpnc vulnerabilities

Vulnerabilities published for network-manager-vpnc in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2026-91841

    High · CVSS 7.8EPSS 0.19%No fix published

    Networkmanager-vpnc: networkmanager-vpnc: incomplete fix for cve-2018-10900 allows root privilege escalation via ca-file path newline injection

    A flaw was found in NetworkManager-vpnc, a VPN plugin for NetworkManager. A local unprivileged user can exploit this vulnerability by injecting a newline character into the CA-File path. This manipulation allows the user to execute arbitrary commands as the root user, leading to local privilege escalation.

    Published Updated
  2. CVE-2026-91840

    High · CVSS 7.8EPSS 0.19%No fix published

    Networkmanager-vpnc: networkmanager-vpnc: local privilege escalation to root via newline injection in vpn username

    A flaw was found in NetworkManager-vpnc. This vulnerability allows a local unprivileged user to escalate privileges to root. By injecting a newline character into the VPN username field, an attacker can manipulate the vpnc configuration to execute an arbitrary program with root privileges when the malicious VPN connection is activated.

    Published Updated
  3. CVE-2024-3661

    High · CVSS 7.6EPSS 4.06%No fix published

    DHCP routing options can manipulate interface-based VPN traffic

    DHCP can add routes to a client’s routing table via the classless static route option (121). VPN-based security solutions that rely on routes to redirect traffic can be forced to leak traffic over the physical interface. An attacker on the same local network can read, disrupt, or possibly modify network traffic that was expected to be protected by the VPN.

    Published Updated
  4. CVE-2018-10900

    High · CVSS 8.8EPSS 3.92%Public exploitFix available

    CVE-2018-10900

    Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.

    • Update to 1.1.93-1ubuntu0.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →