p PatchFirst

CVE-2018-10931

CVE-2018-10931

This page contains facts from public vulnerability sources. Check the original advisory before updating.

It was found that cobbler 2.6.x exposed all functions from its CobblerXMLRPCInterface class over XMLRPC. A remote, unauthenticated attacker could use this flaw to gain high privileges within cobbler, upload files to arbitrary location in the context of the daemon.

CVSS 9.8 · Critical · EPSS 68.1% · Public exploit · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • cobbler

    Versions
    • 2.6.x: Affected

    No fix published

  • cobbler PyPI

    Affected ranges
    • ECOSYSTEM: ≥ 2.6.0, < 3.0.0

    Update to 3.0.0

  • cobbler Ubuntu:Pro:16.04:LTS

    Versions
    • 2.4.1-0ubuntu2
    Affected ranges
    • ECOSYSTEM: < 2.4.1-0ubuntu2+esm1

    Update to 2.4.1-0ubuntu2+esm1

Original sources

Check your server →