p PatchFirst

PatchFirst · Latest vulnerabilities

cobbler vulnerabilities

Vulnerabilities published for cobbler in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 12

  1. CVE-2021-45083

    High · CVSS 8.6EPSS 0.31%Fix available

    CVE-2021-45083

    An issue was discovered in Cobbler before 3.3.1. Files in /etc/cobbler are world readable. Two of those files contain some sensitive information that can be exposed to a local user who has non-privileged access to the server. The users.digest file contains the sha2-512 digest of users in a Cobbler local installation. In the case of an easy-to-guess password, it's trivial to obtain the plaintext string. The settings.yaml file contains secrets such as the hashed default password.

    • Update to 2.4.1-0ubuntu2+esm1
    Published Updated
  2. CVE-2018-1000226

    Critical · CVSS 9.8EPSS 12.58%Public exploitFix available

    CVE-2018-1000226

    Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via "network connectivity". Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.

    • Update to 2.4.1-0ubuntu2+esm1
    Published Updated
  3. CVE-2018-1000225

    Medium · CVSS 6.1EPSS 1.27%Fix available

    CVE-2018-1000225

    Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Cross Site Scripting (XSS) vulnerability in cobbler-web that can result in Privilege escalation to admin.. This attack appear to be exploitable via "network connectivity". Sending unauthenticated JavaScript payload to the Cobbler XMLRPC API (/cobbler_api).

    • Update to 2.4.1-0ubuntu2+esm1
    Published Updated
  4. CVE-2018-10931

    Critical · CVSS 9.8EPSS 68.08%Public exploitFix available

    CVE-2018-10931

    It was found that cobbler 2.6.x exposed all functions from its CobblerXMLRPCInterface class over XMLRPC. A remote, unauthenticated attacker could use this flaw to gain high privileges within cobbler, upload files to arbitrary location in the context of the daemon.

    • Update to 2.4.1-0ubuntu2+esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →