p PatchFirst

CVE-2018-11645

CVE-2018-11645

This page contains facts from public vulnerability sources. Check the original advisory before updating.

psi/zfile.c in Artifex Ghostscript before 9.21rc1 permits the status command even if -dSAFER is used, which might allow remote attackers to determine the existence and size of arbitrary files, a similar issue to CVE-2016-7977.

CVSS 5.3 · Medium · EPSS 2.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ghostscript Debian:12

    Affected ranges
    • ECOSYSTEM: < 9.21~dfsg-1

    Update to 9.21~dfsg-1

  • ghostscript Debian:13

    Affected ranges
    • ECOSYSTEM: < 9.21~dfsg-1

    Update to 9.21~dfsg-1

  • ghostscript Debian:14

    Affected ranges
    • ECOSYSTEM: < 9.21~dfsg-1

    Update to 9.21~dfsg-1

  • ghostscript Ubuntu:14.04:LTS

    Versions
    • 9.10~dfsg-0ubuntu2
    • 9.10~dfsg-0ubuntu3
    • 9.10~dfsg-0ubuntu4
    • 9.10~dfsg-0ubuntu5
    • 9.10~dfsg-0ubuntu6
    • 9.10~dfsg-0ubuntu7
    • 9.10~dfsg-0ubuntu8
    • 9.10~dfsg-0ubuntu9
    • 9.10~dfsg-0ubuntu10
    • 9.10~dfsg-0ubuntu10.1
    • 9.10~dfsg-0ubuntu10.2
    • 9.10~dfsg-0ubuntu10.3
    • 9.10~dfsg-0ubuntu10.4
    • 9.10~dfsg-0ubuntu10.5
    • 9.10~dfsg-0ubuntu10.6
    • 9.10~dfsg-0ubuntu10.7
    • 9.10~dfsg-0ubuntu10.9
    • 9.10~dfsg-0ubuntu10.10
    • 9.10~dfsg-0ubuntu10.12
    Affected ranges
    • ECOSYSTEM: < 9.10~dfsg-0ubuntu10.13

    Update to 9.10~dfsg-0ubuntu10.13

  • ghostscript Ubuntu:16.04:LTS

    Versions
    • 9.16~dfsg~0-0ubuntu3
    • 9.16~dfsg~0-0ubuntu4
    • 9.18~dfsg~0-0ubuntu1
    • 9.18~dfsg~0-0ubuntu2
    • 9.18~dfsg~0-0ubuntu2.2
    • 9.18~dfsg~0-0ubuntu2.3
    • 9.18~dfsg~0-0ubuntu2.4
    • 9.18~dfsg~0-0ubuntu2.6
    • 9.18~dfsg~0-0ubuntu2.7
    • 9.18~dfsg~0-0ubuntu2.8
    Affected ranges
    • ECOSYSTEM: < 9.18~dfsg~0-0ubuntu2.9

    Update to 9.18~dfsg~0-0ubuntu2.9

Original sources

Check your server →