CVE-2018-13988
CVE-2018-13988
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Poppler through 0.62 contains an out of bounds read vulnerability due to an incorrect memory access that is not mapped in its memory space, as demonstrated by pdfunite. This can result in memory corruption and denial of service. This may be exploitable when a victim opens a specially crafted PDF file.
CVSS 6.5 · Medium · EPSS 3.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
poppler Debian:12
- Affected ranges
- ECOSYSTEM: < 0.69.0-2
Update to 0.69.0-2
poppler Debian:13
- Affected ranges
- ECOSYSTEM: < 0.69.0-2
Update to 0.69.0-2
poppler Debian:14
- Affected ranges
- ECOSYSTEM: < 0.69.0-2
Update to 0.69.0-2
poppler Ubuntu:14.04:LTS
- Versions
- 0.24.1-0ubuntu1
- 0.24.3-0ubuntu1
- 0.24.3-0ubuntu2
- 0.24.3-0ubuntu3
- 0.24.3-0ubuntu4
- 0.24.3-0ubuntu5
- 0.24.3-0ubuntu6
- 0.24.3-0ubuntu7
- 0.24.3-0ubuntu8
- 0.24.3-0ubuntu10
- 0.24.3-0ubuntu12
- 0.24.5-0ubuntu3
- 0.24.5-2ubuntu1
- 0.24.5-2ubuntu2
- 0.24.5-2ubuntu4
- 0.24.5-2ubuntu4.1
- 0.24.5-2ubuntu4.2
- 0.24.5-2ubuntu4.3
- 0.24.5-2ubuntu4.4
- 0.24.5-2ubuntu4.5
- 0.24.5-2ubuntu4.6
- 0.24.5-2ubuntu4.7
- 0.24.5-2ubuntu4.8
- 0.24.5-2ubuntu4.9
- 0.24.5-2ubuntu4.11
- Affected ranges
- ECOSYSTEM: < 0.24.5-2ubuntu4.12
Update to 0.24.5-2ubuntu4.12
poppler Ubuntu:16.04:LTS
- Versions
- 0.33.0-0ubuntu3
- 0.37.0-0ubuntu1
- 0.38.0-0ubuntu1
- 0.41.0-0ubuntu1
- 0.41.0-0ubuntu1.1
- 0.41.0-0ubuntu1.2
- 0.41.0-0ubuntu1.3
- 0.41.0-0ubuntu1.4
- 0.41.0-0ubuntu1.5
- 0.41.0-0ubuntu1.6
- 0.41.0-0ubuntu1.7
- Affected ranges
- ECOSYSTEM: < 0.41.0-0ubuntu1.8
Update to 0.41.0-0ubuntu1.8
poppler Ubuntu:18.04:LTS
- Versions
- 0.57.0-2ubuntu4
- 0.57.0-2ubuntu5
- 0.62.0-1ubuntu1
- 0.62.0-2ubuntu1
- 0.62.0-2ubuntu2
- 0.62.0-2ubuntu2.1
- Affected ranges
- ECOSYSTEM: < 0.62.0-2ubuntu2.2
Update to 0.62.0-2ubuntu2.2
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=1602838
- https://lists.debian.org/debian-lts-announce/2018/10/msg00024.html
- https://bugzilla.novell.com/show_bug.cgi?id=CVE-2018-13988
- https://access.redhat.com/errata/RHSA-2018:3505
- https://access.redhat.com/errata/RHSA-2018:3140
- https://cgit.freedesktop.org/poppler/poppler/commit/?id=004e3c10df0abda214f0c293f9e269fdd979c5ee
- http://packetstormsecurity.com/files/148661/PDFunite-0.62.0-Buffer-Overflow.html
- https://usn.ubuntu.com/3757-1/
- https://access.redhat.com/errata/RHBA-2019:0327
- https://nvd.nist.gov/vuln/detail/CVE-2018-13988