CVE-2018-14055
CVE-2018-14055
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing a non-admin user to escalate his privilege and inject rogue values into znc.conf.
CVSS 6.5 · Medium · EPSS 1.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
znc Debian:12
- Affected ranges
- ECOSYSTEM: < 1.7.1-1
Update to 1.7.1-1
znc Debian:13
- Affected ranges
- ECOSYSTEM: < 1.7.1-1
Update to 1.7.1-1
znc Debian:14
- Affected ranges
- ECOSYSTEM: < 1.7.1-1
Update to 1.7.1-1
znc Ubuntu:14.04:LTS
- Versions
- 1.0-5
- 1.0-5build1
- 1.2-1
- 1.2-2
- 1.2-3
- 1.2-3build1
- Affected ranges
- ECOSYSTEM: < 1.2-3ubuntu0.1
Update to 1.2-3ubuntu0.1
znc Ubuntu:16.04:LTS
- Versions
- 1.6.1-1
- 1.6.1-1build1
- 1.6.1-2
- 1.6.2-1
- 1.6.2-2
- 1.6.2-2build1
- 1.6.3-1
- Affected ranges
- ECOSYSTEM: < 1.6.3-1ubuntu0.1
Update to 1.6.3-1ubuntu0.1
znc Ubuntu:18.04:LTS
- Versions
- 1.6.5-2build2
- 1.6.5-2build3
- 1.6.5-2build4
- 1.6.5-2build5
- 1.6.6-1
- Affected ranges
- ECOSYSTEM: < 1.6.6-1ubuntu0.1
Update to 1.6.6-1ubuntu0.1