CVE-2019-12816
Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.
- Update to 1.6.6-1ubuntu0.2
Published Updated
PatchFirst · Latest vulnerabilities
Vulnerabilities published for znc in the last 30 days: 0. Listed in the KEV catalogue: 0.
Vulnerabilities: 3
Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.
ZNC before 1.7.1-rc1 is prone to a path traversal flaw via ../ in a web skin name to access files outside of the intended skins directories.
ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing a non-admin user to escalate his privilege and inject rogue values into znc.conf.
Check your installed stack and versions against the current vulnerability feeds.