p PatchFirst

CVE-2018-16395

CVE-2018-16395

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. When two OpenSSL::X509::Name objects are compared using ==, depending on the ordering, non-equal objects may return true. When the first argument is one character longer than the second, or the second argument contains a character that is one less than a character in the same position of the first argument, the result of == will be true. This could be leveraged to create an illegitimate certificate that may be accepted as legitimate and then used in signing or encryption operations.

CVSS 9.8 · Critical · EPSS 10.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ruby1.9.1 Ubuntu:14.04:LTS

    Versions
    • 1.9.3.194-8.1ubuntu2
    • 1.9.3.448-1ubuntu1
    • 1.9.3.448-1ubuntu2
    • 1.9.3.484-1ubuntu1
    • 1.9.3.484-1ubuntu2
    • 1.9.3.484-2ubuntu1
    • 1.9.3.484-2ubuntu1.1
    • 1.9.3.484-2ubuntu1.2
    • 1.9.3.484-2ubuntu1.3
    • 1.9.3.484-2ubuntu1.5
    • 1.9.3.484-2ubuntu1.6
    • 1.9.3.484-2ubuntu1.7
    • 1.9.3.484-2ubuntu1.8
    • 1.9.3.484-2ubuntu1.10
    • 1.9.3.484-2ubuntu1.11
    • 1.9.3.484-2ubuntu1.12
    Affected ranges
    • ECOSYSTEM: < 1.9.3.484-2ubuntu1.13

    Update to 1.9.3.484-2ubuntu1.13

  • ruby2.0 Ubuntu:14.04:LTS

    Versions
    • 2.0.0.299-2
    • 2.0.0.343-1
    • 2.0.0.343-1ubuntu1
    • 2.0.0.353-1
    • 2.0.0.353-1ubuntu1
    • 2.0.0.484-1ubuntu1
    • 2.0.0.484-1ubuntu2
    • 2.0.0.484-1ubuntu2.1
    • 2.0.0.484-1ubuntu2.2
    • 2.0.0.484-1ubuntu2.4
    • 2.0.0.484-1ubuntu2.5
    • 2.0.0.484-1ubuntu2.6
    • 2.0.0.484-1ubuntu2.8
    • 2.0.0.484-1ubuntu2.9
    • 2.0.0.484-1ubuntu2.10
    Affected ranges
    • ECOSYSTEM: < 2.0.0.484-1ubuntu2.11

    Update to 2.0.0.484-1ubuntu2.11

  • ruby2.3 Ubuntu:16.04:LTS

    Versions
    • 2.3.0-1
    • 2.3.0-2
    • 2.3.0-4ubuntu2
    • 2.3.0-4ubuntu3
    • 2.3.0-5ubuntu1
    • 2.3.1-2~16.04
    • 2.3.1-2~16.04.2
    • 2.3.1-2~16.04.4
    • 2.3.1-2~16.04.5
    • 2.3.1-2~16.04.6
    • 2.3.1-2~16.04.7
    • 2.3.1-2~16.04.9
    • 2.3.1-2~16.04.10
    Affected ranges
    • ECOSYSTEM: < 2.3.1-2~16.04.11

    Update to 2.3.1-2~16.04.11

  • ruby2.5 Ubuntu:18.04:LTS

    Versions
    • 2.5.0~preview1-1ubuntu2
    • 2.5.0-4ubuntu1
    • 2.5.0-4ubuntu4
    • 2.5.0-5ubuntu1
    • 2.5.0-6ubuntu1
    • 2.5.1-1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 2.5.1-1ubuntu1.1

    Update to 2.5.1-1ubuntu1.1

Original sources

Check your server →