CVE-2018-16509
CVE-2018-16509
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in Artifex Ghostscript before 9.24. Incorrect "restoration of privilege" checking during handling of /invalidaccess exceptions could be used by attackers able to supply crafted PostScript to execute code using the "pipe" instruction.
CVSS 7.8 · High · EPSS 92.5% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ghostscript Debian:12
- Affected ranges
- ECOSYSTEM: < 9.25~dfsg-1
Update to 9.25~dfsg-1
ghostscript Debian:13
- Affected ranges
- ECOSYSTEM: < 9.25~dfsg-1
Update to 9.25~dfsg-1
ghostscript Debian:14
- Affected ranges
- ECOSYSTEM: < 9.25~dfsg-1
Update to 9.25~dfsg-1
ghostscript Ubuntu:14.04:LTS
- Versions
- 9.10~dfsg-0ubuntu2
- 9.10~dfsg-0ubuntu3
- 9.10~dfsg-0ubuntu4
- 9.10~dfsg-0ubuntu5
- 9.10~dfsg-0ubuntu6
- 9.10~dfsg-0ubuntu7
- 9.10~dfsg-0ubuntu8
- 9.10~dfsg-0ubuntu9
- 9.10~dfsg-0ubuntu10
- 9.10~dfsg-0ubuntu10.1
- 9.10~dfsg-0ubuntu10.2
- 9.10~dfsg-0ubuntu10.3
- 9.10~dfsg-0ubuntu10.4
- 9.10~dfsg-0ubuntu10.5
- 9.10~dfsg-0ubuntu10.6
- 9.10~dfsg-0ubuntu10.7
- 9.10~dfsg-0ubuntu10.9
- 9.10~dfsg-0ubuntu10.10
- 9.10~dfsg-0ubuntu10.12
- Affected ranges
- ECOSYSTEM: < 9.10~dfsg-0ubuntu10.13
Update to 9.10~dfsg-0ubuntu10.13
ghostscript Ubuntu:16.04:LTS
- Versions
- 9.16~dfsg~0-0ubuntu3
- 9.16~dfsg~0-0ubuntu4
- 9.18~dfsg~0-0ubuntu1
- 9.18~dfsg~0-0ubuntu2
- 9.18~dfsg~0-0ubuntu2.2
- 9.18~dfsg~0-0ubuntu2.3
- 9.18~dfsg~0-0ubuntu2.4
- 9.18~dfsg~0-0ubuntu2.6
- 9.18~dfsg~0-0ubuntu2.7
- 9.18~dfsg~0-0ubuntu2.8
- Affected ranges
- ECOSYSTEM: < 9.18~dfsg~0-0ubuntu2.9
Update to 9.18~dfsg~0-0ubuntu2.9
ghostscript Ubuntu:18.04:LTS
- Versions
- 9.21~dfsg+1-0ubuntu3
- 9.22~dfsg+1-0ubuntu1
- 9.22~dfsg+1-0ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 9.22~dfsg+1-0ubuntu1.2
Update to 9.22~dfsg+1-0ubuntu1.2
Original sources
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=5516c614dc33662a2afdc377159f70218e67bde5
- https://www.exploit-db.com/exploits/45369/
- https://bugs.ghostscript.com/show_bug.cgi?id=699654
- https://access.redhat.com/errata/RHSA-2018:2918
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=79cccf641486a6595c43f1de1cd7ade696020a31
- https://security.gentoo.org/glsa/201811-12
- https://usn.ubuntu.com/3768-1/
- https://www.artifex.com/news/ghostscript-security-resolved/
- https://access.redhat.com/errata/RHSA-2018:3760
- http://seclists.org/oss-sec/2018/q3/142
- https://www.debian.org/security/2018/dsa-4294
- https://lists.debian.org/debian-lts-announce/2018/09/msg00015.html
- http://www.securityfocus.com/bid/105122
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=78911a01b67d590b4a91afac2e8417360b934156
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=520bb0ea7519aa3e79db78aaf0589dae02103764
- https://nvd.nist.gov/vuln/detail/CVE-2018-16509