CVE-2018-16513
CVE-2018-16513
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Artifex Ghostscript before 9.24, attackers able to supply crafted PostScript files could use a type confusion in the setcolor function to crash the interpreter or possibly have unspecified other impact.
CVSS 7.8 · High · EPSS 1.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ghostscript Debian:12
- Affected ranges
- ECOSYSTEM: < 9.22~dfsg-3
Update to 9.22~dfsg-3
ghostscript Debian:13
- Affected ranges
- ECOSYSTEM: < 9.22~dfsg-3
Update to 9.22~dfsg-3
ghostscript Debian:14
- Affected ranges
- ECOSYSTEM: < 9.22~dfsg-3
Update to 9.22~dfsg-3
ghostscript Ubuntu:14.04:LTS
- Versions
- 9.10~dfsg-0ubuntu2
- 9.10~dfsg-0ubuntu3
- 9.10~dfsg-0ubuntu4
- 9.10~dfsg-0ubuntu5
- 9.10~dfsg-0ubuntu6
- 9.10~dfsg-0ubuntu7
- 9.10~dfsg-0ubuntu8
- 9.10~dfsg-0ubuntu9
- 9.10~dfsg-0ubuntu10
- 9.10~dfsg-0ubuntu10.1
- 9.10~dfsg-0ubuntu10.2
- 9.10~dfsg-0ubuntu10.3
- 9.10~dfsg-0ubuntu10.4
- 9.10~dfsg-0ubuntu10.5
- 9.10~dfsg-0ubuntu10.6
- 9.10~dfsg-0ubuntu10.7
- 9.10~dfsg-0ubuntu10.9
- 9.10~dfsg-0ubuntu10.10
- 9.10~dfsg-0ubuntu10.12
- Affected ranges
- ECOSYSTEM: < 9.10~dfsg-0ubuntu10.13
Update to 9.10~dfsg-0ubuntu10.13
ghostscript Ubuntu:16.04:LTS
- Versions
- 9.16~dfsg~0-0ubuntu3
- 9.16~dfsg~0-0ubuntu4
- 9.18~dfsg~0-0ubuntu1
- 9.18~dfsg~0-0ubuntu2
- 9.18~dfsg~0-0ubuntu2.2
- 9.18~dfsg~0-0ubuntu2.3
- 9.18~dfsg~0-0ubuntu2.4
- 9.18~dfsg~0-0ubuntu2.6
- 9.18~dfsg~0-0ubuntu2.7
- 9.18~dfsg~0-0ubuntu2.8
- Affected ranges
- ECOSYSTEM: < 9.18~dfsg~0-0ubuntu2.9
Update to 9.18~dfsg~0-0ubuntu2.9
ghostscript Ubuntu:18.04:LTS
- Versions
- 9.21~dfsg+1-0ubuntu3
- 9.22~dfsg+1-0ubuntu1
- 9.22~dfsg+1-0ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 9.22~dfsg+1-0ubuntu1.2
Update to 9.22~dfsg+1-0ubuntu1.2
Original sources
- https://security.gentoo.org/glsa/201811-12
- https://usn.ubuntu.com/3768-1/
- https://www.artifex.com/news/ghostscript-security-resolved/
- https://bugs.ghostscript.com/show_bug.cgi?id=699655
- https://www.debian.org/security/2018/dsa-4288
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=b326a71659b7837d3acde954b18bda1a6f5e9498
- https://lists.debian.org/debian-lts-announce/2018/09/msg00015.html
- https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44101
- https://support.f5.com/csp/article/K22141757?utm_source=f5support&%3Butm_medium=RSS
- https://nvd.nist.gov/vuln/detail/CVE-2018-16513