p PatchFirst

CVE-2018-16585

CVE-2018-16585

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in Artifex Ghostscript before 9.24. The .setdistillerkeys PostScript command is accepted even though it is not intended for use during document processing (e.g., after the startup phase). This leads to memory corruption, allowing remote attackers able to supply crafted PostScript to crash the interpreter or possibly have unspecified other impact. Note: A reputable source believes that the CVE is potentially a duplicate of CVE-2018-15910 as explained in Red Hat bugzilla (https://bugzilla.redhat.com/show_bug.cgi?id=1626193)

CVSS 7.8 · High · EPSS 1.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ghostscript Debian:12

    Affected ranges
    • ECOSYSTEM: < 9.25~dfsg-1

    Update to 9.25~dfsg-1

  • ghostscript Debian:13

    Affected ranges
    • ECOSYSTEM: < 9.25~dfsg-1

    Update to 9.25~dfsg-1

  • ghostscript Debian:14

    Affected ranges
    • ECOSYSTEM: < 9.25~dfsg-1

    Update to 9.25~dfsg-1

  • ghostscript Ubuntu:14.04:LTS

    Versions
    • 9.10~dfsg-0ubuntu2
    • 9.10~dfsg-0ubuntu3
    • 9.10~dfsg-0ubuntu4
    • 9.10~dfsg-0ubuntu5
    • 9.10~dfsg-0ubuntu6
    • 9.10~dfsg-0ubuntu7
    • 9.10~dfsg-0ubuntu8
    • 9.10~dfsg-0ubuntu9
    • 9.10~dfsg-0ubuntu10
    • 9.10~dfsg-0ubuntu10.1
    • 9.10~dfsg-0ubuntu10.2
    • 9.10~dfsg-0ubuntu10.3
    • 9.10~dfsg-0ubuntu10.4
    • 9.10~dfsg-0ubuntu10.5
    • 9.10~dfsg-0ubuntu10.6
    • 9.10~dfsg-0ubuntu10.7
    • 9.10~dfsg-0ubuntu10.9
    • 9.10~dfsg-0ubuntu10.10
    • 9.10~dfsg-0ubuntu10.12
    Affected ranges
    • ECOSYSTEM: < 9.10~dfsg-0ubuntu10.13

    Update to 9.10~dfsg-0ubuntu10.13

  • ghostscript Ubuntu:16.04:LTS

    Versions
    • 9.16~dfsg~0-0ubuntu3
    • 9.16~dfsg~0-0ubuntu4
    • 9.18~dfsg~0-0ubuntu1
    • 9.18~dfsg~0-0ubuntu2
    • 9.18~dfsg~0-0ubuntu2.2
    • 9.18~dfsg~0-0ubuntu2.3
    • 9.18~dfsg~0-0ubuntu2.4
    • 9.18~dfsg~0-0ubuntu2.6
    • 9.18~dfsg~0-0ubuntu2.7
    • 9.18~dfsg~0-0ubuntu2.8
    Affected ranges
    • ECOSYSTEM: < 9.18~dfsg~0-0ubuntu2.9

    Update to 9.18~dfsg~0-0ubuntu2.9

Original sources

Check your server →