p PatchFirst

CVE-2018-16802

CVE-2018-16802

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in Artifex Ghostscript before 9.25. Incorrect "restoration of privilege" checking when running out of stack during exception handling could be used by attackers able to supply crafted PostScript to execute code using the "pipe" instruction. This is due to an incomplete fix for CVE-2018-16509.

CVSS 7.8 · High · EPSS 2.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ghostscript Debian:12

    Affected ranges
    • ECOSYSTEM: < 9.25~dfsg-1

    Update to 9.25~dfsg-1

  • ghostscript Debian:13

    Affected ranges
    • ECOSYSTEM: < 9.25~dfsg-1

    Update to 9.25~dfsg-1

  • ghostscript Debian:14

    Affected ranges
    • ECOSYSTEM: < 9.25~dfsg-1

    Update to 9.25~dfsg-1

  • ghostscript Ubuntu:14.04:LTS

    Versions
    • 9.10~dfsg-0ubuntu2
    • 9.10~dfsg-0ubuntu3
    • 9.10~dfsg-0ubuntu4
    • 9.10~dfsg-0ubuntu5
    • 9.10~dfsg-0ubuntu6
    • 9.10~dfsg-0ubuntu7
    • 9.10~dfsg-0ubuntu8
    • 9.10~dfsg-0ubuntu9
    • 9.10~dfsg-0ubuntu10
    • 9.10~dfsg-0ubuntu10.1
    • 9.10~dfsg-0ubuntu10.2
    • 9.10~dfsg-0ubuntu10.3
    • 9.10~dfsg-0ubuntu10.4
    • 9.10~dfsg-0ubuntu10.5
    • 9.10~dfsg-0ubuntu10.6
    • 9.10~dfsg-0ubuntu10.7
    • 9.10~dfsg-0ubuntu10.9
    • 9.10~dfsg-0ubuntu10.10
    • 9.10~dfsg-0ubuntu10.12
    Affected ranges
    • ECOSYSTEM: < 9.10~dfsg-0ubuntu10.13

    Update to 9.10~dfsg-0ubuntu10.13

  • ghostscript Ubuntu:16.04:LTS

    Versions
    • 9.16~dfsg~0-0ubuntu3
    • 9.16~dfsg~0-0ubuntu4
    • 9.18~dfsg~0-0ubuntu1
    • 9.18~dfsg~0-0ubuntu2
    • 9.18~dfsg~0-0ubuntu2.2
    • 9.18~dfsg~0-0ubuntu2.3
    • 9.18~dfsg~0-0ubuntu2.4
    • 9.18~dfsg~0-0ubuntu2.6
    • 9.18~dfsg~0-0ubuntu2.7
    • 9.18~dfsg~0-0ubuntu2.8
    Affected ranges
    • ECOSYSTEM: < 9.18~dfsg~0-0ubuntu2.9

    Update to 9.18~dfsg~0-0ubuntu2.9

  • ghostscript Ubuntu:18.04:LTS

    Versions
    • 9.21~dfsg+1-0ubuntu3
    • 9.22~dfsg+1-0ubuntu1
    • 9.22~dfsg+1-0ubuntu1.1
    Affected ranges
    • ECOSYSTEM: < 9.22~dfsg+1-0ubuntu1.2

    Update to 9.22~dfsg+1-0ubuntu1.2

Original sources

Check your server →