p PatchFirst

CVE-2018-19296

CVE-2018-19296

This page contains facts from public vulnerability sources. Check the original advisory before updating.

PHPMailer before 5.2.27 and 6.x before 6.0.6 is vulnerable to an object injection attack.

CVSS 8.8 · High · EPSS 2.2% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libphp-phpmailer Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.2.14+dfsg-2.4

    Update to 5.2.14+dfsg-2.4

  • libphp-phpmailer Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.2.14+dfsg-2.4

    Update to 5.2.14+dfsg-2.4

  • libphp-phpmailer Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.2.14+dfsg-2.4

    Update to 5.2.14+dfsg-2.4

  • phpmailer/phpmailer Packagist

    Versions
    • v5.2.10
    • v5.2.11
    • v5.2.12
    • v5.2.13
    • v5.2.14
    • v5.2.15
    • v5.2.16
    • v5.2.17
    • v5.2.18
    • v5.2.19
    • v5.2.2
    • v5.2.20
    • v5.2.21
    • v5.2.22
    • v5.2.23
    • v5.2.24
    • v5.2.25
    • v5.2.26
    • v5.2.4
    • v5.2.5
    • v5.2.6
    • v5.2.7
    • v5.2.8
    • v5.2.9
    Affected ranges
    • ECOSYSTEM: ≥ 5.0.0, < 5.2.27

    Update to 5.2.27

  • phpmailer/phpmailer Packagist

    Versions
    • v6.0.0
    • v6.0.1
    • v6.0.2
    • v6.0.3
    • v6.0.4
    • v6.0.5
    Affected ranges
    • ECOSYSTEM: ≥ 6.0.0, < 6.0.6

    Update to 6.0.6

  • libphp-phpmailer Ubuntu:Pro:16.04:LTS

    Versions
    • 5.2.10+dfsg-1
    • 5.2.14+dfsg-1
    • 5.2.14+dfsg-1build1
    Affected ranges
    • ECOSYSTEM: < 5.2.14+dfsg-1ubuntu0.1~esm1

    Update to 5.2.14+dfsg-1ubuntu0.1~esm1

  • libphp-phpmailer Ubuntu:18.04:LTS

    Versions
    • 5.2.14+dfsg-2.3
    Affected ranges
    • ECOSYSTEM: < 5.2.14+dfsg-2.3+deb9u1build0.18.04.1

    Update to 5.2.14+dfsg-2.3+deb9u1build0.18.04.1

Original sources

Check your server →