CVE-2018-19409
CVE-2018-19409
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in Artifex Ghostscript before 9.26. LockSafetyParams is not checked correctly if another device is used.
CVSS 9.8 · Critical · EPSS 7.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ghostscript Debian:12
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg-1
Update to 9.26~dfsg-1
ghostscript Debian:13
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg-1
Update to 9.26~dfsg-1
ghostscript Debian:14
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg-1
Update to 9.26~dfsg-1
ghostscript Ubuntu:14.04:LTS
- Versions
- 9.10~dfsg-0ubuntu2
- 9.10~dfsg-0ubuntu3
- 9.10~dfsg-0ubuntu4
- 9.10~dfsg-0ubuntu5
- 9.10~dfsg-0ubuntu6
- 9.10~dfsg-0ubuntu7
- 9.10~dfsg-0ubuntu8
- 9.10~dfsg-0ubuntu9
- 9.10~dfsg-0ubuntu10
- 9.10~dfsg-0ubuntu10.1
- 9.10~dfsg-0ubuntu10.2
- 9.10~dfsg-0ubuntu10.3
- 9.10~dfsg-0ubuntu10.4
- 9.10~dfsg-0ubuntu10.5
- 9.10~dfsg-0ubuntu10.6
- 9.10~dfsg-0ubuntu10.7
- 9.10~dfsg-0ubuntu10.9
- 9.10~dfsg-0ubuntu10.10
- 9.10~dfsg-0ubuntu10.12
- 9.10~dfsg-0ubuntu10.13
- 9.25~dfsg+1-0ubuntu0.14.04.1
- 9.25~dfsg+1-0ubuntu0.14.04.2
- 9.25~dfsg+1-0ubuntu0.14.04.3
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.14.04.1
Update to 9.26~dfsg+0-0ubuntu0.14.04.1
ghostscript Ubuntu:16.04:LTS
- Versions
- 9.16~dfsg~0-0ubuntu3
- 9.16~dfsg~0-0ubuntu4
- 9.18~dfsg~0-0ubuntu1
- 9.18~dfsg~0-0ubuntu2
- 9.18~dfsg~0-0ubuntu2.2
- 9.18~dfsg~0-0ubuntu2.3
- 9.18~dfsg~0-0ubuntu2.4
- 9.18~dfsg~0-0ubuntu2.6
- 9.18~dfsg~0-0ubuntu2.7
- 9.18~dfsg~0-0ubuntu2.8
- 9.18~dfsg~0-0ubuntu2.9
- 9.25~dfsg+1-0ubuntu0.16.04.1
- 9.25~dfsg+1-0ubuntu0.16.04.2
- 9.25~dfsg+1-0ubuntu0.16.04.3
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.16.04.1
Update to 9.26~dfsg+0-0ubuntu0.16.04.1
ghostscript Ubuntu:18.04:LTS
- Versions
- 9.21~dfsg+1-0ubuntu3
- 9.22~dfsg+1-0ubuntu1
- 9.22~dfsg+1-0ubuntu1.1
- 9.22~dfsg+1-0ubuntu1.2
- 9.25~dfsg+1-0ubuntu0.18.04.1
- 9.25~dfsg+1-0ubuntu0.18.04.2
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.18.04.1
Update to 9.26~dfsg+0-0ubuntu0.18.04.1
Original sources
- https://www.debian.org/security/2018/dsa-4346
- https://security.gentoo.org/glsa/201811-12
- https://usn.ubuntu.com/3831-1/
- http://www.securityfocus.com/bid/105990
- https://bugs.ghostscript.com/show_bug.cgi?id=700176
- https://access.redhat.com/errata/RHSA-2018:3834
- https://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=661e8d8fb8248c38d67958beda32f3a5876d0c3f
- https://lists.debian.org/debian-lts-announce/2018/11/msg00036.html
- https://www.ghostscript.com/doc/9.26/History9.htm#Version9.26
- https://nvd.nist.gov/vuln/detail/CVE-2018-19409