p PatchFirst

CVE-2018-20650

CVE-2018-20650

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A reachable Object::dictLookup assertion in Poppler 0.72.0 allows attackers to cause a denial of service due to the lack of a check for the dict data type, as demonstrated by use of the FileSpec class (in FileSpec.cc) in pdfdetach.

CVSS 6.5 · Medium · EPSS 2.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • poppler Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.85.0-2

    Update to 0.85.0-2

  • poppler Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.85.0-2

    Update to 0.85.0-2

  • poppler Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.85.0-2

    Update to 0.85.0-2

  • poppler Ubuntu:14.04:LTS

    Versions
    • 0.24.1-0ubuntu1
    • 0.24.3-0ubuntu1
    • 0.24.3-0ubuntu2
    • 0.24.3-0ubuntu3
    • 0.24.3-0ubuntu4
    • 0.24.3-0ubuntu5
    • 0.24.3-0ubuntu6
    • 0.24.3-0ubuntu7
    • 0.24.3-0ubuntu8
    • 0.24.3-0ubuntu10
    • 0.24.3-0ubuntu12
    • 0.24.5-0ubuntu3
    • 0.24.5-2ubuntu1
    • 0.24.5-2ubuntu2
    • 0.24.5-2ubuntu4
    • 0.24.5-2ubuntu4.1
    • 0.24.5-2ubuntu4.2
    • 0.24.5-2ubuntu4.3
    • 0.24.5-2ubuntu4.4
    • 0.24.5-2ubuntu4.5
    • 0.24.5-2ubuntu4.6
    • 0.24.5-2ubuntu4.7
    • 0.24.5-2ubuntu4.8
    • 0.24.5-2ubuntu4.9
    • 0.24.5-2ubuntu4.11
    • 0.24.5-2ubuntu4.12
    • 0.24.5-2ubuntu4.13
    • 0.24.5-2ubuntu4.14
    Affected ranges
    • ECOSYSTEM: < 0.24.5-2ubuntu4.15

    Update to 0.24.5-2ubuntu4.15

  • poppler Ubuntu:16.04:LTS

    Versions
    • 0.33.0-0ubuntu3
    • 0.37.0-0ubuntu1
    • 0.38.0-0ubuntu1
    • 0.41.0-0ubuntu1
    • 0.41.0-0ubuntu1.1
    • 0.41.0-0ubuntu1.2
    • 0.41.0-0ubuntu1.3
    • 0.41.0-0ubuntu1.4
    • 0.41.0-0ubuntu1.5
    • 0.41.0-0ubuntu1.6
    • 0.41.0-0ubuntu1.7
    • 0.41.0-0ubuntu1.8
    • 0.41.0-0ubuntu1.9
    • 0.41.0-0ubuntu1.10
    Affected ranges
    • ECOSYSTEM: < 0.41.0-0ubuntu1.11

    Update to 0.41.0-0ubuntu1.11

  • poppler Ubuntu:18.04:LTS

    Versions
    • 0.57.0-2ubuntu4
    • 0.57.0-2ubuntu5
    • 0.62.0-1ubuntu1
    • 0.62.0-2ubuntu1
    • 0.62.0-2ubuntu2
    • 0.62.0-2ubuntu2.1
    • 0.62.0-2ubuntu2.2
    • 0.62.0-2ubuntu2.4
    • 0.62.0-2ubuntu2.5
    Affected ranges
    • ECOSYSTEM: < 0.62.0-2ubuntu2.6

    Update to 0.62.0-2ubuntu2.6

Original sources

Check your server →