CVE-2018-8778
CVE-2018-8778
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker controlling the unpacking format (similar to format string vulnerabilities) can trigger a buffer under-read in the String#unpack method, resulting in a massive and controlled information disclosure.
CVSS 7.5 · High · EPSS 7.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ruby1.9.1 Ubuntu:14.04:LTS
- Versions
- 1.9.3.194-8.1ubuntu2
- 1.9.3.448-1ubuntu1
- 1.9.3.448-1ubuntu2
- 1.9.3.484-1ubuntu1
- 1.9.3.484-1ubuntu2
- 1.9.3.484-2ubuntu1
- 1.9.3.484-2ubuntu1.1
- 1.9.3.484-2ubuntu1.2
- 1.9.3.484-2ubuntu1.3
- 1.9.3.484-2ubuntu1.5
- 1.9.3.484-2ubuntu1.6
- 1.9.3.484-2ubuntu1.7
- 1.9.3.484-2ubuntu1.8
- 1.9.3.484-2ubuntu1.10
- Affected ranges
- ECOSYSTEM: < 1.9.3.484-2ubuntu1.11
Update to 1.9.3.484-2ubuntu1.11
ruby2.0 Ubuntu:14.04:LTS
- Versions
- 2.0.0.299-2
- 2.0.0.343-1
- 2.0.0.343-1ubuntu1
- 2.0.0.353-1
- 2.0.0.353-1ubuntu1
- 2.0.0.484-1ubuntu1
- 2.0.0.484-1ubuntu2
- 2.0.0.484-1ubuntu2.1
- 2.0.0.484-1ubuntu2.2
- 2.0.0.484-1ubuntu2.4
- 2.0.0.484-1ubuntu2.5
- 2.0.0.484-1ubuntu2.6
- 2.0.0.484-1ubuntu2.8
- Affected ranges
- ECOSYSTEM: < 2.0.0.484-1ubuntu2.9
Update to 2.0.0.484-1ubuntu2.9
ruby2.3 Ubuntu:16.04:LTS
- Versions
- 2.3.0-1
- 2.3.0-2
- 2.3.0-4ubuntu2
- 2.3.0-4ubuntu3
- 2.3.0-5ubuntu1
- 2.3.1-2~16.04
- 2.3.1-2~16.04.2
- 2.3.1-2~16.04.4
- 2.3.1-2~16.04.5
- 2.3.1-2~16.04.6
- 2.3.1-2~16.04.7
- Affected ranges
- ECOSYSTEM: < 2.3.1-2~16.04.9
Update to 2.3.1-2~16.04.9
Original sources
- https://www.ruby-lang.org/en/news/2018/03/28/ruby-2-5-1-released/
- https://access.redhat.com/errata/RHSA-2018:3729
- https://usn.ubuntu.com/3626-1/
- http://www.securitytracker.com/id/1042004
- https://access.redhat.com/errata/RHSA-2018:3730
- https://lists.debian.org/debian-lts-announce/2018/04/msg00023.html
- https://access.redhat.com/errata/RHSA-2018:3731
- https://www.ruby-lang.org/en/news/2018/03/28/ruby-2-3-7-released/
- https://www.ruby-lang.org/en/news/2018/03/28/buffer-under-read-unpack-cve-2018-8778/
- https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- https://www.ruby-lang.org/en/news/2018/03/28/ruby-2-4-4-released/
- https://www.debian.org/security/2018/dsa-4259
- https://www.ruby-lang.org/en/news/2018/03/28/ruby-2-2-10-released/
- https://lists.debian.org/debian-lts-announce/2018/04/msg00024.html
- http://www.securityfocus.com/bid/103693
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
- https://access.redhat.com/errata/RHSA-2019:2028
- https://nvd.nist.gov/vuln/detail/CVE-2018-8778