p PatchFirst

CVE-2019-12816

CVE-2019-12816

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.

CVSS 8.8 · High · EPSS 4.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • znc Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.7.2-3

    Update to 1.7.2-3

  • znc Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.7.2-3

    Update to 1.7.2-3

  • znc Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.7.2-3

    Update to 1.7.2-3

  • znc Ubuntu:Pro:14.04:LTS

    Versions
    • 1.0-5
    • 1.0-5build1
    • 1.2-1
    • 1.2-2
    • 1.2-3
    • 1.2-3build1
    • 1.2-3ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 1.2-3ubuntu0.1+esm1

    Update to 1.2-3ubuntu0.1+esm1

  • znc Ubuntu:16.04:LTS

    Versions
    • 1.6.1-1
    • 1.6.1-1build1
    • 1.6.1-2
    • 1.6.2-1
    • 1.6.2-2
    • 1.6.2-2build1
    • 1.6.3-1
    • 1.6.3-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 1.6.3-1ubuntu0.2

    Update to 1.6.3-1ubuntu0.2

  • znc Ubuntu:18.04:LTS

    Versions
    • 1.6.5-2build2
    • 1.6.5-2build3
    • 1.6.5-2build4
    • 1.6.5-2build5
    • 1.6.6-1
    • 1.6.6-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 1.6.6-1ubuntu0.2

    Update to 1.6.6-1ubuntu0.2

Original sources

Check your server →