p PatchFirst

CVE-2019-13627

CVE-2019-13627

This page contains facts from public vulnerability sources. Check the original advisory before updating.

It was discovered that there was a ECDSA timing attack in the libgcrypt20 cryptographic library. Version affected: 1.8.4-5, 1.7.6-2+deb9u3, and 1.6.3-2+deb8u4. Versions fixed: 1.8.5-2 and 1.6.3-2+deb8u7.

CVSS 6.3 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libgcrypt20 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.8.5-1

    Update to 1.8.5-1

  • libgcrypt20 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.8.5-1

    Update to 1.8.5-1

  • libgcrypt20 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.8.5-1

    Update to 1.8.5-1

  • libgcrypt11 Ubuntu:Pro:14.04:LTS

    Versions
    • 1.5.0-3ubuntu3
    • 1.5.3-2ubuntu1
    • 1.5.3-2ubuntu4
    • 1.5.3-2ubuntu4.1
    • 1.5.3-2ubuntu4.2
    • 1.5.3-2ubuntu4.3
    • 1.5.3-2ubuntu4.4
    • 1.5.3-2ubuntu4.5
    • 1.5.3-2ubuntu4.6
    Affected ranges
    • ECOSYSTEM: < 1.5.3-2ubuntu4.6+esm1

    Update to 1.5.3-2ubuntu4.6+esm1

  • libgcrypt20 Ubuntu:16.04:LTS

    Versions
    • 1.6.3-2ubuntu1
    • 1.6.4-3
    • 1.6.4-4
    • 1.6.4-5
    • 1.6.5-2
    • 1.6.5-2ubuntu0.2
    • 1.6.5-2ubuntu0.3
    • 1.6.5-2ubuntu0.4
    • 1.6.5-2ubuntu0.5
    Affected ranges
    • ECOSYSTEM: < 1.6.5-2ubuntu0.6

    Update to 1.6.5-2ubuntu0.6

  • libgcrypt20 Ubuntu:18.04:LTS

    Versions
    • 1.7.8-2ubuntu1
    • 1.7.9-1
    • 1.8.1-4
    • 1.8.1-4ubuntu1
    • 1.8.1-4ubuntu1.1
    Affected ranges
    • ECOSYSTEM: < 1.8.1-4ubuntu1.2

    Update to 1.8.1-4ubuntu1.2

Original sources

Check your server →