CVE-2019-20042
CVE-2019-20042
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In wp-includes/formatting.php in WordPress 3.7 to 5.3.0, the function wp_targeted_link_rel() can be used in a particular way to result in a stored cross-site scripting (XSS) vulnerability. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release.
CVSS 6.1 · Medium · EPSS 2.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 5.3.2+dfsg1-1
Update to 5.3.2+dfsg1-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 5.3.2+dfsg1-1
Update to 5.3.2+dfsg1-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 5.3.2+dfsg1-1
Update to 5.3.2+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:18.04:LTS
- Versions
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://wpvulndb.com/vulnerabilities/9975
- https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/
- https://core.trac.wordpress.org/changeset/46894/trunk
- https://github.com/WordPress/wordpress-develop/commit/1f7f3f1f59567e2504f0fbebd51ccf004b3ccb1d
- https://blog.ripstech.com/filter/vulnerabilities/
- https://seclists.org/bugtraq/2020/Jan/8
- https://www.debian.org/security/2020/dsa-4599
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-xvg2-m2f4-83m7
- https://hackerone.com/reports/509930
- https://www.debian.org/security/2020/dsa-4677
- https://nvd.nist.gov/vuln/detail/CVE-2019-20042