p PatchFirst

CVE-2019-3813

CVE-2019-3813

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in memslot_get_virt. This may lead to a denial of service, or, in the worst case, code-execution by unauthenticated attackers.

CVSS 7.5 · High · EPSS 1.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • spice

    Versions
    • versions 0.5.2 through 0.14.1: Affected

    No fix published

  • spice Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.14.0-1.3

    Update to 0.14.0-1.3

  • spice Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.14.0-1.3

    Update to 0.14.0-1.3

  • spice Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.14.0-1.3

    Update to 0.14.0-1.3

  • spice Ubuntu:14.04:LTS

    Versions
    • 0.12.4-0nocelt1
    • 0.12.4-0nocelt1.1
    • 0.12.4-0nocelt1.1ubuntu1
    • 0.12.4-0nocelt2
    • 0.12.4-0nocelt2ubuntu1
    • 0.12.4-0nocelt2ubuntu1.1
    • 0.12.4-0nocelt2ubuntu1.2
    • 0.12.4-0nocelt2ubuntu1.3
    • 0.12.4-0nocelt2ubuntu1.4
    • 0.12.4-0nocelt2ubuntu1.5
    • 0.12.4-0nocelt2ubuntu1.6
    • 0.12.4-0nocelt2ubuntu1.7
    Affected ranges
    • ECOSYSTEM: < 0.12.4-0nocelt2ubuntu1.8

    Update to 0.12.4-0nocelt2ubuntu1.8

  • spice Ubuntu:16.04:LTS

    Versions
    • 0.12.5-1.1ubuntu2
    • 0.12.6-4
    • 0.12.6-4ubuntu0.1
    • 0.12.6-4ubuntu0.2
    • 0.12.6-4ubuntu0.3
    Affected ranges
    • ECOSYSTEM: < 0.12.6-4ubuntu0.4

    Update to 0.12.6-4ubuntu0.4

  • spice Ubuntu:18.04:LTS

    Versions
    • 0.12.8-2.2
    • 0.14.0-1
    • 0.14.0-1ubuntu1
    • 0.14.0-1ubuntu2
    • 0.14.0-1ubuntu2.1
    • 0.14.0-1ubuntu2.2
    Affected ranges
    • ECOSYSTEM: < 0.14.0-1ubuntu2.4

    Update to 0.14.0-1ubuntu2.4

Original sources

Check your server →