CVE-2019-3838
CVE-2019-3838
This page contains facts from public vulnerability sources. Check the original advisory before updating.
It was found that the forceput operator could be extracted from the DefineResource method in ghostscript before 9.27. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER.
CVSS 7.3 · High · EPSS 2.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ghostscript
- Versions
- 9.27: Affected
No fix published
ghostscript Debian:12
- Affected ranges
- ECOSYSTEM: < 9.27~dfsg-1
Update to 9.27~dfsg-1
ghostscript Debian:13
- Affected ranges
- ECOSYSTEM: < 9.27~dfsg-1
Update to 9.27~dfsg-1
ghostscript Debian:14
- Affected ranges
- ECOSYSTEM: < 9.27~dfsg-1
Update to 9.27~dfsg-1
ghostscript Ubuntu:14.04:LTS
- Versions
- 9.10~dfsg-0ubuntu2
- 9.10~dfsg-0ubuntu3
- 9.10~dfsg-0ubuntu4
- 9.10~dfsg-0ubuntu5
- 9.10~dfsg-0ubuntu6
- 9.10~dfsg-0ubuntu7
- 9.10~dfsg-0ubuntu8
- 9.10~dfsg-0ubuntu9
- 9.10~dfsg-0ubuntu10
- 9.10~dfsg-0ubuntu10.1
- 9.10~dfsg-0ubuntu10.2
- 9.10~dfsg-0ubuntu10.3
- 9.10~dfsg-0ubuntu10.4
- 9.10~dfsg-0ubuntu10.5
- 9.10~dfsg-0ubuntu10.6
- 9.10~dfsg-0ubuntu10.7
- 9.10~dfsg-0ubuntu10.9
- 9.10~dfsg-0ubuntu10.10
- 9.10~dfsg-0ubuntu10.12
- 9.10~dfsg-0ubuntu10.13
- 9.25~dfsg+1-0ubuntu0.14.04.1
- 9.25~dfsg+1-0ubuntu0.14.04.2
- 9.25~dfsg+1-0ubuntu0.14.04.3
- 9.26~dfsg+0-0ubuntu0.14.04.1
- 9.26~dfsg+0-0ubuntu0.14.04.3
- 9.26~dfsg+0-0ubuntu0.14.04.4
- 9.26~dfsg+0-0ubuntu0.14.04.5
- 9.26~dfsg+0-0ubuntu0.14.04.6
- 9.26~dfsg+0-0ubuntu0.14.04.7
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.14.04.8
Update to 9.26~dfsg+0-0ubuntu0.14.04.8
ghostscript Ubuntu:16.04:LTS
- Versions
- 9.16~dfsg~0-0ubuntu3
- 9.16~dfsg~0-0ubuntu4
- 9.18~dfsg~0-0ubuntu1
- 9.18~dfsg~0-0ubuntu2
- 9.18~dfsg~0-0ubuntu2.2
- 9.18~dfsg~0-0ubuntu2.3
- 9.18~dfsg~0-0ubuntu2.4
- 9.18~dfsg~0-0ubuntu2.6
- 9.18~dfsg~0-0ubuntu2.7
- 9.18~dfsg~0-0ubuntu2.8
- 9.18~dfsg~0-0ubuntu2.9
- 9.25~dfsg+1-0ubuntu0.16.04.1
- 9.25~dfsg+1-0ubuntu0.16.04.2
- 9.25~dfsg+1-0ubuntu0.16.04.3
- 9.26~dfsg+0-0ubuntu0.16.04.1
- 9.26~dfsg+0-0ubuntu0.16.04.3
- 9.26~dfsg+0-0ubuntu0.16.04.4
- 9.26~dfsg+0-0ubuntu0.16.04.5
- 9.26~dfsg+0-0ubuntu0.16.04.6
- 9.26~dfsg+0-0ubuntu0.16.04.7
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.16.04.8
Update to 9.26~dfsg+0-0ubuntu0.16.04.8
ghostscript Ubuntu:18.04:LTS
- Versions
- 9.21~dfsg+1-0ubuntu3
- 9.22~dfsg+1-0ubuntu1
- 9.22~dfsg+1-0ubuntu1.1
- 9.22~dfsg+1-0ubuntu1.2
- 9.25~dfsg+1-0ubuntu0.18.04.1
- 9.25~dfsg+1-0ubuntu0.18.04.2
- 9.26~dfsg+0-0ubuntu0.18.04.1
- 9.26~dfsg+0-0ubuntu0.18.04.3
- 9.26~dfsg+0-0ubuntu0.18.04.4
- 9.26~dfsg+0-0ubuntu0.18.04.5
- 9.26~dfsg+0-0ubuntu0.18.04.6
- 9.26~dfsg+0-0ubuntu0.18.04.7
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.18.04.8
Update to 9.26~dfsg+0-0ubuntu0.18.04.8
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3838
- https://bugs.ghostscript.com/show_bug.cgi?id=700576
- https://access.redhat.com/errata/RHSA-2019:0652
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SVERLGEU3OV6RNZ2SIBXREWD3BF5H23N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ANBSCZABXQUEQWIKNWJ35IYX24M227EI/
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00018.html
- https://seclists.org/bugtraq/2019/Apr/4
- http://packetstormsecurity.com/files/152367/Slackware-Security-Advisory-ghostscript-Updates.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/A43SRQAEHQCKSEMIBINHUNIGHTDCZD7F/
- https://www.debian.org/security/2019/dsa-4432
- https://seclists.org/bugtraq/2019/Apr/28
- https://lists.debian.org/debian-lts-announce/2019/04/msg00021.html
- https://access.redhat.com/errata/RHSA-2019:0971
- https://security.gentoo.org/glsa/202004-03
- https://nvd.nist.gov/vuln/detail/CVE-2019-3838