CVE-2019-6116
CVE-2019-6116
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Artifex Ghostscript through 9.26, ephemeral or transient procedures can allow access to system operators, leading to remote code execution.
CVSS 7.8 · High · EPSS 41.6% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ghostscript Debian:12
- Affected ranges
- ECOSYSTEM: < 9.26a~dfsg-1
Update to 9.26a~dfsg-1
ghostscript Debian:13
- Affected ranges
- ECOSYSTEM: < 9.26a~dfsg-1
Update to 9.26a~dfsg-1
ghostscript Debian:14
- Affected ranges
- ECOSYSTEM: < 9.26a~dfsg-1
Update to 9.26a~dfsg-1
ghostscript Ubuntu:14.04:LTS
- Versions
- 9.10~dfsg-0ubuntu2
- 9.10~dfsg-0ubuntu3
- 9.10~dfsg-0ubuntu4
- 9.10~dfsg-0ubuntu5
- 9.10~dfsg-0ubuntu6
- 9.10~dfsg-0ubuntu7
- 9.10~dfsg-0ubuntu8
- 9.10~dfsg-0ubuntu9
- 9.10~dfsg-0ubuntu10
- 9.10~dfsg-0ubuntu10.1
- 9.10~dfsg-0ubuntu10.2
- 9.10~dfsg-0ubuntu10.3
- 9.10~dfsg-0ubuntu10.4
- 9.10~dfsg-0ubuntu10.5
- 9.10~dfsg-0ubuntu10.6
- 9.10~dfsg-0ubuntu10.7
- 9.10~dfsg-0ubuntu10.9
- 9.10~dfsg-0ubuntu10.10
- 9.10~dfsg-0ubuntu10.12
- 9.10~dfsg-0ubuntu10.13
- 9.25~dfsg+1-0ubuntu0.14.04.1
- 9.25~dfsg+1-0ubuntu0.14.04.2
- 9.25~dfsg+1-0ubuntu0.14.04.3
- 9.26~dfsg+0-0ubuntu0.14.04.1
- 9.26~dfsg+0-0ubuntu0.14.04.3
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.14.04.4
Update to 9.26~dfsg+0-0ubuntu0.14.04.4
ghostscript Ubuntu:16.04:LTS
- Versions
- 9.16~dfsg~0-0ubuntu3
- 9.16~dfsg~0-0ubuntu4
- 9.18~dfsg~0-0ubuntu1
- 9.18~dfsg~0-0ubuntu2
- 9.18~dfsg~0-0ubuntu2.2
- 9.18~dfsg~0-0ubuntu2.3
- 9.18~dfsg~0-0ubuntu2.4
- 9.18~dfsg~0-0ubuntu2.6
- 9.18~dfsg~0-0ubuntu2.7
- 9.18~dfsg~0-0ubuntu2.8
- 9.18~dfsg~0-0ubuntu2.9
- 9.25~dfsg+1-0ubuntu0.16.04.1
- 9.25~dfsg+1-0ubuntu0.16.04.2
- 9.25~dfsg+1-0ubuntu0.16.04.3
- 9.26~dfsg+0-0ubuntu0.16.04.1
- 9.26~dfsg+0-0ubuntu0.16.04.3
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.16.04.4
Update to 9.26~dfsg+0-0ubuntu0.16.04.4
ghostscript Ubuntu:18.04:LTS
- Versions
- 9.21~dfsg+1-0ubuntu3
- 9.22~dfsg+1-0ubuntu1
- 9.22~dfsg+1-0ubuntu1.1
- 9.22~dfsg+1-0ubuntu1.2
- 9.25~dfsg+1-0ubuntu0.18.04.1
- 9.25~dfsg+1-0ubuntu0.18.04.2
- 9.26~dfsg+0-0ubuntu0.18.04.1
- 9.26~dfsg+0-0ubuntu0.18.04.3
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.18.04.4
Update to 9.26~dfsg+0-0ubuntu0.18.04.4
Original sources
- https://access.redhat.com/errata/RHSA-2019:0229
- http://www.securityfocus.com/bid/106700
- https://usn.ubuntu.com/3866-1/
- https://www.exploit-db.com/exploits/46242/
- https://lists.debian.org/debian-lts-announce/2019/02/msg00016.html
- http://packetstormsecurity.com/files/151307/Ghostscript-Pseudo-Operator-Remote-Code-Execution.html
- https://www.debian.org/security/2019/dsa-4372
- https://bugs.chromium.org/p/project-zero/issues/detail?id=1729
- http://lists.opensuse.org/opensuse-security-announce/2019-01/msg00047.html
- http://lists.opensuse.org/opensuse-security-announce/2019-01/msg00048.html
- http://www.openwall.com/lists/oss-security/2019/01/23/5
- https://bugs.ghostscript.com/show_bug.cgi?id=700317
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MWVAVCDXBLPLJMVGNSKGGDTBEOHCJBKK/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7N6T5L3SSJX2AVUPHP7GCPATFWUPKZT2/
- http://www.openwall.com/lists/oss-security/2019/03/21/1
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XVWXVKG72IGEJYHLWE6H3CGALHGFSGGY/
- https://seclists.org/bugtraq/2019/Apr/4
- http://packetstormsecurity.com/files/152367/Slackware-Security-Advisory-ghostscript-Updates.html
- https://access.redhat.com/errata/RHBA-2019:0327
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZP34D27RKYV2POJ3NJLSVCHUA5V5C45A/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6AATIHU32MYKUOXQDJQU4X4DDVL7NAY3/
- https://security.gentoo.org/glsa/202004-03
- https://nvd.nist.gov/vuln/detail/CVE-2019-6116