CVE-2019-8320
CVE-2019-8320
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A Directory Traversal issue was discovered in RubyGems 2.7.6 and later through 3.0.2. Before making new directories or touching files (which now include path-checking code for symlinks), it would delete the target destination. If that destination was hidden behind a symlink, a malicious gem could delete arbitrary files on the user's machine, presuming the attacker could guess at paths. Given how frequently gem is run as sudo, and how predictable paths are on modern systems (/tmp, /usr, etc.), this could likely lead to data loss or an unusable system.
CVSS 7.4 · High · EPSS 4.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
jruby Debian:12
- Affected ranges
- ECOSYSTEM: < 9.1.17.0-3
Update to 9.1.17.0-3
jruby Debian:13
- Affected ranges
- ECOSYSTEM: < 9.1.17.0-3
Update to 9.1.17.0-3
jruby Debian:14
- Affected ranges
- ECOSYSTEM: < 9.1.17.0-3
Update to 9.1.17.0-3
rubygems Debian:12
- Affected ranges
- ECOSYSTEM: < 3.2.0~rc.1-1
Update to 3.2.0~rc.1-1
rubygems Debian:13
- Affected ranges
- ECOSYSTEM: < 3.2.0~rc.1-1
Update to 3.2.0~rc.1-1
rubygems Debian:14
- Affected ranges
- ECOSYSTEM: < 3.2.0~rc.1-1
Update to 3.2.0~rc.1-1
ruby1.9.1 Ubuntu:14.04:LTS
- Versions
- 1.9.3.194-8.1ubuntu2
- 1.9.3.448-1ubuntu1
- 1.9.3.448-1ubuntu2
- 1.9.3.484-1ubuntu1
- 1.9.3.484-1ubuntu2
- 1.9.3.484-2ubuntu1
- 1.9.3.484-2ubuntu1.1
- 1.9.3.484-2ubuntu1.2
- 1.9.3.484-2ubuntu1.3
- 1.9.3.484-2ubuntu1.5
- 1.9.3.484-2ubuntu1.6
- 1.9.3.484-2ubuntu1.7
- 1.9.3.484-2ubuntu1.8
- 1.9.3.484-2ubuntu1.10
- 1.9.3.484-2ubuntu1.11
- 1.9.3.484-2ubuntu1.12
- 1.9.3.484-2ubuntu1.13
- Affected ranges
- ECOSYSTEM: < 1.9.3.484-2ubuntu1.14
Update to 1.9.3.484-2ubuntu1.14
ruby2.0 Ubuntu:14.04:LTS
- Versions
- 2.0.0.299-2
- 2.0.0.343-1
- 2.0.0.343-1ubuntu1
- 2.0.0.353-1
- 2.0.0.353-1ubuntu1
- 2.0.0.484-1ubuntu1
- 2.0.0.484-1ubuntu2
- 2.0.0.484-1ubuntu2.1
- 2.0.0.484-1ubuntu2.2
- 2.0.0.484-1ubuntu2.4
- 2.0.0.484-1ubuntu2.5
- 2.0.0.484-1ubuntu2.6
- 2.0.0.484-1ubuntu2.8
- 2.0.0.484-1ubuntu2.9
- 2.0.0.484-1ubuntu2.10
- 2.0.0.484-1ubuntu2.11
- Affected ranges
- ECOSYSTEM: < 2.0.0.484-1ubuntu2.13
Update to 2.0.0.484-1ubuntu2.13
ruby2.3 Ubuntu:16.04:LTS
- Versions
- 2.3.0-1
- 2.3.0-2
- 2.3.0-4ubuntu2
- 2.3.0-4ubuntu3
- 2.3.0-5ubuntu1
- 2.3.1-2~16.04
- 2.3.1-2~16.04.2
- 2.3.1-2~16.04.4
- 2.3.1-2~16.04.5
- 2.3.1-2~16.04.6
- 2.3.1-2~16.04.7
- 2.3.1-2~16.04.9
- 2.3.1-2~16.04.10
- 2.3.1-2~16.04.11
- Affected ranges
- ECOSYSTEM: < 2.3.1-2~16.04.12
Update to 2.3.1-2~16.04.12
ruby2.5 Ubuntu:18.04:LTS
- Versions
- 2.5.0~preview1-1ubuntu2
- 2.5.0-4ubuntu1
- 2.5.0-4ubuntu4
- 2.5.0-5ubuntu1
- 2.5.0-6ubuntu1
- 2.5.1-1ubuntu1
- 2.5.1-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 2.5.1-1ubuntu1.2
Update to 2.5.1-1ubuntu1.2
jruby Ubuntu:18.04:LTS
- Versions
- 9.1.13.0-1
- 9.1.17.0-1~18.04
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://hackerone.com/reports/317321
- https://blog.rubygems.org/2019/03/05/security-advisories-2019-03.html
- https://access.redhat.com/errata/RHSA-2019:1429
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
- https://lists.debian.org/debian-lts-announce/2020/08/msg00027.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-8320