p PatchFirst

CVE-2019-9200

CVE-2019-9200

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A heap-based buffer underwrite exists in ImageStream::getLine() located at Stream.cc in Poppler 0.74.0 that can (for example) be triggered by sending a crafted PDF file to the pdfimages binary. It allows an attacker to cause Denial of Service (Segmentation fault) or possibly have unspecified other impact.

CVSS 8.8 · High · EPSS 3.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • poppler Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.71.0-4

    Update to 0.71.0-4

  • poppler Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.71.0-4

    Update to 0.71.0-4

  • poppler Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.71.0-4

    Update to 0.71.0-4

  • poppler Ubuntu:14.04:LTS

    Versions
    • 0.24.1-0ubuntu1
    • 0.24.3-0ubuntu1
    • 0.24.3-0ubuntu2
    • 0.24.3-0ubuntu3
    • 0.24.3-0ubuntu4
    • 0.24.3-0ubuntu5
    • 0.24.3-0ubuntu6
    • 0.24.3-0ubuntu7
    • 0.24.3-0ubuntu8
    • 0.24.3-0ubuntu10
    • 0.24.3-0ubuntu12
    • 0.24.5-0ubuntu3
    • 0.24.5-2ubuntu1
    • 0.24.5-2ubuntu2
    • 0.24.5-2ubuntu4
    • 0.24.5-2ubuntu4.1
    • 0.24.5-2ubuntu4.2
    • 0.24.5-2ubuntu4.3
    • 0.24.5-2ubuntu4.4
    • 0.24.5-2ubuntu4.5
    • 0.24.5-2ubuntu4.6
    • 0.24.5-2ubuntu4.7
    • 0.24.5-2ubuntu4.8
    • 0.24.5-2ubuntu4.9
    • 0.24.5-2ubuntu4.11
    • 0.24.5-2ubuntu4.12
    • 0.24.5-2ubuntu4.13
    • 0.24.5-2ubuntu4.14
    • 0.24.5-2ubuntu4.15
    • 0.24.5-2ubuntu4.16
    Affected ranges
    • ECOSYSTEM: < 0.24.5-2ubuntu4.17

    Update to 0.24.5-2ubuntu4.17

  • poppler Ubuntu:16.04:LTS

    Versions
    • 0.33.0-0ubuntu3
    • 0.37.0-0ubuntu1
    • 0.38.0-0ubuntu1
    • 0.41.0-0ubuntu1
    • 0.41.0-0ubuntu1.1
    • 0.41.0-0ubuntu1.2
    • 0.41.0-0ubuntu1.3
    • 0.41.0-0ubuntu1.4
    • 0.41.0-0ubuntu1.5
    • 0.41.0-0ubuntu1.6
    • 0.41.0-0ubuntu1.7
    • 0.41.0-0ubuntu1.8
    • 0.41.0-0ubuntu1.9
    • 0.41.0-0ubuntu1.10
    • 0.41.0-0ubuntu1.11
    • 0.41.0-0ubuntu1.12
    Affected ranges
    • ECOSYSTEM: < 0.41.0-0ubuntu1.13

    Update to 0.41.0-0ubuntu1.13

  • poppler Ubuntu:18.04:LTS

    Versions
    • 0.57.0-2ubuntu4
    • 0.57.0-2ubuntu5
    • 0.62.0-1ubuntu1
    • 0.62.0-2ubuntu1
    • 0.62.0-2ubuntu2
    • 0.62.0-2ubuntu2.1
    • 0.62.0-2ubuntu2.2
    • 0.62.0-2ubuntu2.4
    • 0.62.0-2ubuntu2.5
    • 0.62.0-2ubuntu2.6
    • 0.62.0-2ubuntu2.7
    Affected ranges
    • ECOSYSTEM: < 0.62.0-2ubuntu2.8

    Update to 0.62.0-2ubuntu2.8

Original sources

Check your server →