p PatchFirst

CVE-2020-5263

CVE-2020-5263 · Information disclosure through error object

This page contains facts from public vulnerability sources. Check the original advisory before updating.

auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3

CVSS 5.5 · Medium · EPSS 0.9% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • auth0.js

    Versions
    • >= 8.0.0, < 9.12.3: Affected

    No fix published

  • auth0-js npm

    Affected ranges
    • SEMVER: ≥ 8.0.0, < 9.13.2

    Update to 9.13.2

Original sources

Check your server →