p PatchFirst

CVE-2021-27803

CVE-2021-27803

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was discovered in how p2p/p2p_pd.c in wpa_supplicant before 2.10 processes P2P (Wi-Fi Direct) provision discovery requests. It could result in denial of service or other impact (potentially execution of arbitrary code), for an attacker within radio range.

CVSS 7.5 · High · EPSS 1.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wpa Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:2.9.0-21

    Update to 2:2.9.0-21

  • wpa Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:2.9.0-21

    Update to 2:2.9.0-21

  • wpa Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:2.9.0-21

    Update to 2:2.9.0-21

  • wpa Ubuntu:Pro:14.04:LTS

    Versions
    • 1.0-3ubuntu2
    • 1.0-3ubuntu3
    • 1.0-3ubuntu4
    • 2.1-0ubuntu1
    • 2.1-0ubuntu1.1
    • 2.1-0ubuntu1.2
    • 2.1-0ubuntu1.3
    • 2.1-0ubuntu1.4
    • 2.1-0ubuntu1.5
    • 2.1-0ubuntu1.6
    • 2.1-0ubuntu1.7
    • 2.1-0ubuntu1.7+esm1
    • 2.1-0ubuntu1.7+esm2
    • 2.1-0ubuntu1.7+esm3
    Affected ranges
    • ECOSYSTEM: < 2.1-0ubuntu1.7+esm4

    Update to 2.1-0ubuntu1.7+esm4

  • wpa Ubuntu:16.04:LTS

    Versions
    • 2.4-0ubuntu3
    • 2.4-0ubuntu4
    • 2.4-0ubuntu5
    • 2.4-0ubuntu6
    • 2.4-0ubuntu6.2
    • 2.4-0ubuntu6.3
    • 2.4-0ubuntu6.4
    • 2.4-0ubuntu6.5
    • 2.4-0ubuntu6.6
    • 2.4-0ubuntu6.7
    Affected ranges
    • ECOSYSTEM: < 2.4-0ubuntu6.8

    Update to 2.4-0ubuntu6.8

  • wpa Ubuntu:18.04:LTS

    Versions
    • 2.4-0ubuntu10
    • 2:2.4-1.1ubuntu1
    • 2:2.6-15ubuntu1
    • 2:2.6-15ubuntu2
    • 2:2.6-15ubuntu2.1
    • 2:2.6-15ubuntu2.2
    • 2:2.6-15ubuntu2.3
    • 2:2.6-15ubuntu2.4
    • 2:2.6-15ubuntu2.5
    • 2:2.6-15ubuntu2.6
    • 2:2.6-15ubuntu2.7
    Affected ranges
    • ECOSYSTEM: < 2:2.6-15ubuntu2.8

    Update to 2:2.6-15ubuntu2.8

  • wpa Ubuntu:20.04:LTS

    Versions
    • 2:2.9-1ubuntu2
    • 2:2.9-1ubuntu3
    • 2:2.9-1ubuntu4
    • 2:2.9-1ubuntu4.1
    • 2:2.9-1ubuntu4.2
    Affected ranges
    • ECOSYSTEM: < 2:2.9-1ubuntu4.3

    Update to 2:2.9-1ubuntu4.3

Original sources

Check your server →