CVE-2021-29625
CVE-2021-29625 · XSS in doc_link
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`).
CVSS 7.5 · High · EPSS 9.6% · Public exploit · Fix available
- Published
- Updated
Affected products and versions
adminer
- Versions
- >= 4.7.8, < 4.8.1: Affected
No fix published
adminer Debian:12
- Affected ranges
- ECOSYSTEM: < 4.7.9-2
Update to 4.7.9-2
adminer Debian:13
- Affected ranges
- ECOSYSTEM: < 4.7.9-2
Update to 4.7.9-2
adminer Debian:14
- Affected ranges
- ECOSYSTEM: < 4.7.9-2
Update to 4.7.9-2
vrana/adminer Packagist
- Versions
- v4.7.8
- v4.7.9
- v4.8.0
- Affected ranges
- ECOSYSTEM: ≥ 4.7.8, < 4.8.1
Update to 4.8.1
adminer Ubuntu:Pro:18.04:LTS
- Versions
- 4.3.1-2
- 4.5.0-1
- 4.6.1-1
- 4.6.2-1
- Affected ranges
- ECOSYSTEM: < 4.6.2-1ubuntu0.1~esm1
Update to 4.6.2-1ubuntu0.1~esm1
adminer Ubuntu:Pro:20.04:LTS
- Versions
- 4.7.2-1
- 4.7.4-1
- 4.7.5-1
- 4.7.6-1
- Affected ranges
- ECOSYSTEM: < 4.7.6-1ubuntu0.1~esm1
Update to 4.7.6-1ubuntu0.1~esm1