p PatchFirst

PatchFirst · Latest vulnerabilities

vrana/adminer vulnerabilities

Vulnerabilities published for vrana/adminer in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2026-25892

    High · CVSS 7.5EPSS 1.72%Public exploitFix available

    Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint

    Adminer is open-source database management software. Adminer v5.4.1 and earlier has a version check mechanism where adminer.org sends signed version info via JavaScript postMessage, which the browser then POSTs to ?script=version. This endpoint lacks origin validation and accepts POST data from any source. An attacker can POST version[] parameter which PHP converts to an array. On next page load, openssl_verify() receives this array instead of string and throws TypeError, returning HTTP 500 to all users. Upgrade to Adminer 5.4.2.

    • Update to 5.4.2
    Published Updated
  2. CVE-2025-43960

    High · CVSS 8.6EPSS 0.73%No fix published

    CVE-2025-43960

    Adminer 4.8.1, when using Monolog for logging, allows a Denial of Service (memory consumption) via a crafted serialized payload (e.g., using s:1000000000), leading to a PHP Object Injection issue. Remote, unauthenticated attackers can trigger this by sending a malicious serialized object, which forces excessive memory usage, rendering Adminer’s interface unresponsive and causing a server-level DoS. While the server may recover after several minutes, multiple simultaneous requests can cause a complete crash requiring manual intervention.

    Published Updated
  3. CVE-2021-29625

    High · CVSS 7.5EPSS 9.57%Public exploitFix available

    XSS in doc_link

    Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PH

    • Update to 4.8.1
    Published Updated
  4. CVE-2021-21311

    High · CVSS 7.2EPSS 98.46%In KEVPublic exploitFix available

    SSRF in adminer

    Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.

    • Update to 4.7.9
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →