p PatchFirst

PatchFirst · Latest vulnerabilities

libgcrypt20 vulnerabilities

Vulnerabilities published for libgcrypt20 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2021-40528

    Medium · CVSS 5.9EPSS 1.42%Fix available

    CVE-2021-40528

    The ElGamal implementation in Libgcrypt before 1.9.4 allows plaintext recovery because, during interaction between two cryptographic libraries, a certain dangerous combination of the prime defined by the receiver's public key, the generator defined by the receiver's public key, and the sender's ephemeral exponents can lead to a cross-configuration attack against OpenPGP.

    • Update to 1.8.5-5ubuntu1.fips.1.1
    Published Updated
  2. CVE-2021-33560

    High · CVSS 7.5EPSS 2.37%Fix available

    CVE-2021-33560

    Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. This, for example, affects use of ElGamal in OpenPGP.

    • Update to 1.8.5-5ubuntu1.fips.1.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →