CVE-2022-27479
CVE-2022-27479 · SQL injection vulnerability in chart data API
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Apache Superset before 1.4.2 is vulnerable to SQL injection in chart data requests. Users should update to 1.4.2 or higher which addresses this issue.
CVSS 9.8 · Critical · EPSS 2.9% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache superset
- Versions
- ≥ unspecified, < 1.4.2: Affected (custom)
Update to 1.4.2
apache-superset PyPI
- Versions
- 0.34.0
- 0.34.1
- 0.35.1
- 0.35.2
- 0.36.0
- 0.37.0
- 0.37.1
- 0.37.2
- 0.38.0
- 0.38.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- Affected ranges
- ECOSYSTEM: < 1.4.2
Update to 1.4.2