p PatchFirst

PatchFirst · Latest vulnerabilities

@sentry/node-core vulnerabilities

Vulnerabilities published for @sentry/node-core in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 1

  1. CVE-2025-65944

    Medium · CVSS 5.1EPSS 0.37%Fix available

    Sentry-Javascript deals with leaked sensitive headers when `sendDefaultPii` is set to `true`

    Sentry-Javascript is an official Sentry SDKs for JavaScript. From version 10.11.0 to before 10.27.0, when a Node.js application using the Sentry SDK has sendDefaultPii: true it is possible to inadvertently send certain sensitive HTTP headers, including the Cookie header, to Sentry. Those headers would be stored within a Sentry organization as part of the associated trace. A person with access to the Sentry organization could then view and use these sensitive values to impersonate or escalate their privileges within the application. This issue has been patched in version 10.27.0.

    • Update to 10.27.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →