p PatchFirst

CVE-2026-34502

CVE-2026-34502 · Apache Portable Runtime Utility: Heap buffer overflow in APR memcached client

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility memcached client This issue affects Apache Portable Runtime Utility: from 1.3.0 through 1.6.3.

CVSS 7.5 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache portable runtime utility

    Versions
    • ≥ 1.3.0, ≤ 1.6.3: Affected (semver)

    No fix published

  • apr-util Debian:12

    Versions
    • 1.6.3-1
    Affected ranges
    • ECOSYSTEM: < 1.6.3-1+deb12u1

    Update to 1.6.3-1+deb12u1

  • apr-util Debian:13

    Versions
    • 1.6.3-3
    Affected ranges
    • ECOSYSTEM: < 1.6.3-3+deb13u1

    Update to 1.6.3-3+deb13u1

  • apr-util Debian:14

    Versions
    • 1.6.3-3
    • 1.6.3-4
    Affected ranges
    • ECOSYSTEM: < 1.6.4-1

    Update to 1.6.4-1

  • apr-util Ubuntu:Pro:14.04:LTS

    Versions
    • 1.5.2-1
    • 1.5.2-1build1
    • 1.5.2-2ubuntu1
    • 1.5.3-1
    • 1.5.3-1ubuntu0.1~esm1
    • 1.5.3-1ubuntu0.1~esm2
    Affected ranges
    • ECOSYSTEM: < 1.5.3-1ubuntu0.1~esm3

    Update to 1.5.3-1ubuntu0.1~esm3

  • apr-util Ubuntu:Pro:18.04:LTS

    Versions
    • 1.6.0-2
    • 1.6.1-1
    • 1.6.1-1ubuntu2
    • 1.6.1-2
    • 1.6.1-2ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 1.6.1-2ubuntu0.1+esm1

    Update to 1.6.1-2ubuntu0.1+esm1

  • apr-util Ubuntu:Pro:20.04:LTS

    Versions
    • 1.6.1-4build1
    • 1.6.1-4ubuntu1
    • 1.6.1-4ubuntu2
    • 1.6.1-4ubuntu2.1
    • 1.6.1-4ubuntu2.2
    Affected ranges
    • ECOSYSTEM: < 1.6.1-4ubuntu2.2+esm1

    Update to 1.6.1-4ubuntu2.2+esm1

  • apr-util Ubuntu:22.04:LTS

    Versions
    • 1.6.1-5ubuntu2
    • 1.6.1-5ubuntu3
    • 1.6.1-5ubuntu4
    • 1.6.1-5ubuntu4.22.04.1
    • 1.6.1-5ubuntu4.22.04.2
    Affected ranges
    • ECOSYSTEM: < 1.6.1-5ubuntu4.22.04.3

    Update to 1.6.1-5ubuntu4.22.04.3

  • apr-util Ubuntu:24.04:LTS

    Versions
    • 1.6.3-1ubuntu1
    • 1.6.3-1.1ubuntu5
    • 1.6.3-1.1ubuntu6
    • 1.6.3-1.1ubuntu7
    Affected ranges
    • ECOSYSTEM: < 1.6.3-1.1ubuntu7.1

    Update to 1.6.3-1.1ubuntu7.1

  • apr-util Ubuntu:26.04:LTS

    Versions
    • 1.6.3-3ubuntu2
    • 1.6.3-3ubuntu3
    Affected ranges
    • ECOSYSTEM: < 1.6.3-3ubuntu3.1

    Update to 1.6.3-3ubuntu3.1

Original sources

Check your server →