p PatchFirst

PatchFirst · Latest vulnerabilities

apr-util vulnerabilities

Vulnerabilities published for apr-util in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2025-49506

    High · CVSS 7.5EPSS 0.38%Fix available

    Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack

    APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as  Windows, BeOS, NetWare, or Android. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

    • Update to 1.6.1-4ubuntu2.2+esm1
    Published Updated
  2. CVE-2026-32327

    Critical · CVSS 9.1EPSS 0.46%Fix available

    Apache Portable Runtime Utility: apr-util XML stack recursion crash

    A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

    • Update to 1.6.1-4ubuntu2.2+esm1
    Published Updated
  3. CVE-2026-34501

    High · CVSS 7.5EPSS 0.51%Fix available

    Apache Portable Runtime Utility: Heap buffer overflow in APR redis client

    Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility redis client. This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3. Users are recommended to upgrade to version 1.6.4, which fixes the issue.

    • Update to 1.6.1-4ubuntu2.2+esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →