CVE-2026-41990
CVE-2026-41990
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds check but do not use attacker-controlled data.
CVSS 4.0 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libgcrypt
- Versions
- ≥ 1.12.0, < 1.12.2: Affected (semver)
Update to 1.12.2
libgcrypt20 Debian:14
- Versions
- 1.11.0+git20250114-1
- 1.11.0-7
- 1.11.1-1
- 1.11.2-1
- 1.11.2-2
- 1.11.2-3
- 1.12.0-1
- 1.12.0-2
- 1.12.1-1
- 1.12.1-2
- Affected ranges
- ECOSYSTEM: < 1.12.2-1
Update to 1.12.2-1
libgcrypt20 Ubuntu:Pro:FIPS-updates:24.04:LTS
- Versions
- 1.10.3-2ubuntu0.1~Fips1~rc6
- 1.10.3-2ubuntu0.1~Fips1~rc7
- Affected ranges
- ECOSYSTEM: < 1.12.0-2ubuntu0.1~Fips1~rc11
Update to 1.12.0-2ubuntu0.1~Fips1~rc11
libgcrypt20 Ubuntu:26.04:LTS
- Versions
- 1.11.0-7build1
- 1.11.2-2
- 1.11.2-3
- 1.12.0-2
- Affected ranges
- ECOSYSTEM: < 1.12.0-2ubuntu0.1
Update to 1.12.0-2ubuntu0.1