p PatchFirst

CVE-2026-47760

CVE-2026-47760 · TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs

This page contains facts from public vulnerability sources. Check the original advisory before updating.

TinyMCE is an open source rich text editor. From 6.8.0 to before 7.1.0, TinyMCE contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested elements can bypass attribute sanitization and execute arbitrary JavaScript. This vulnerability is fixed in 7.1.0.

CVSS 8.7 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: system · php · node

Affected products and versions

  • tinymce

    Versions
    • >= 6.0.0, < 7.1.0: Affected

    No fix published

  • tinymce npm

    Affected ranges
    • SEMVER: ≥ 6.8.0, < 7.1.0

    Update to 7.1.0

  • tinymce NuGet

    Versions
    • 6.8.0
    • 6.8.1
    • 6.8.2
    • 6.8.3
    • 6.8.4
    • 6.8.5
    • 6.8.6
    • 7.0.0
    • 7.0.1
    Affected ranges
    • ECOSYSTEM: ≥ 6.8.0, < 7.1.0

    Update to 7.1.0

  • tinymce/tinymce Packagist

    Versions
    • 6.8.0
    • 6.8.1
    • 6.8.2
    • 6.8.3
    • 6.8.4
    • 6.8.5
    • 6.8.6
    • 7.0.0
    • 7.0.1
    Affected ranges
    • ECOSYSTEM: ≥ 6.8.0, < 7.1.0

    Update to 7.1.0

  • tinymce Ubuntu:16.04:LTS

    Versions
    • 3.4.8+dfsg0-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • tinymce Ubuntu:18.04:LTS

    Versions
    • 3.4.8+dfsg0-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • tinymce Ubuntu:20.04:LTS

    Versions
    • 3.4.8+dfsg0-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →