p PatchFirst

PatchFirst · Latest vulnerabilities

civicrm vulnerabilities

Vulnerabilities published for civicrm in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 7

  1. CVE-2026-72558

    High · CVSS 8.8EPSS 0.43%No fix published

    CiviCRM CiviCRM - SQL Injection

    An SQL injection vulnerability in CiviCRM through 6.18.alpha1 allows authenticated staff to read the entire database via the contact search RLIKE clause. The clause concatenates a user-supplied value into the SQL query without sanitization. An attacker with staff-level access can exfiltrate all database contents including donor and member records.

    Published Updated
  2. CVE-2023-28115

    Critical · CVSS 9.8EPSS 2.76%No fix published

    Snappy vulnerable to PHAR deserialization, allowing remote code execution

    Snappy is a PHP library allowing thumbnail, snapshot or PDF generation from a url or a html page. Prior to version 1.4.2, Snappy is vulnerable to PHAR deserialization due to a lack of checking on the protocol before passing it into the `file_exists()` function. If an attacker can upload files of any type to the server he can pass in the phar:// protocol to unserialize the uploaded file and instantiate arbitrary PHP objects. This can lead to remote code execution especially when snappy is used with frameworks with documented POP chains like Laravel/Symfony vulnerable developer code. If a user can control the output file from the `generateFromH

    Published Updated
  3. CVE-2018-1999022

    Critical · CVSS 9.8EPSS 2.21%Fix available

    CVE-2018-1999022

    PEAR HTML_QuickForm version 3.2.14 contains an eval injection (CWE-95) vulnerability in HTML_QuickForm's getSubmitValue method, HTML_QuickForm's validate method, HTML_QuickForm_hierselect's _setOptions method, HTML_QuickForm_element's _findValue method, HTML_QuickForm_element's _prepareValue method. that can result in Possible information disclosure, possible impact on data integrity and execution of arbitrary code. This attack appear to be exploitable via A specially crafted query string could be utilised, e.g. http://www.example.com/admin/add_practice_type_id[1]=fubar%27])%20OR%20die(%27OOK!%27);%20//&mode=live. This vulnerability appears t

    • Update to 5.3.1+dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →