p PatchFirst

PatchFirst · Latest vulnerabilities

nginx vulnerabilities · Page 3

Vulnerabilities published for nginx in the last 30 days: 5. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 64

  1. CVE-2018-16844

    Medium · CVSS 5.3EPSS 12.73%Fix available

    CVE-2018-16844

    nginx before versions 1.15.6 and 1.14.1 has a vulnerability in the implementation of HTTP/2 that can allow for excessive CPU usage. This issue affects nginx compiled with the ngx_http_v2_module (not compiled by default) if the 'http2' option of the 'listen' directive is used in a configuration file.

    • Update to 1.14.1-1
    Published Updated
  2. CVE-2018-16843

    Medium · CVSS 5.3EPSS 47.98%Fix available

    CVE-2018-16843

    nginx before versions 1.15.6 and 1.14.1 has a vulnerability in the implementation of HTTP/2 that can allow for excessive memory consumption. This issue affects nginx compiled with the ngx_http_v2_module (not compiled by default) if the 'http2' option of the 'listen' directive is used in a configuration file.

    • Update to 1.14.1-1
    Published Updated
  3. CVE-2016-1247

    High · CVSS 7.8EPSS 4.86%Public exploitFix available

    CVE-2016-1247

    The nginx package before 1.6.2-5+deb8u3 on Debian jessie, the nginx packages before 1.4.6-1ubuntu3.6 on Ubuntu 14.04 LTS, before 1.10.0-0ubuntu0.16.04.3 on Ubuntu 16.04 LTS, and before 1.10.1-0ubuntu1.1 on Ubuntu 16.10, and the nginx ebuild before 1.10.2-r3 on Gentoo allow local users with access to the web server user account to gain root privileges via a symlink attack on the error log.

    • Update to 1.10.2-1
    Published Updated
  4. CVE-2016-0746

    Critical · CVSS 9.8EPSS 8.86%Fix available

    CVE-2016-0746

    Use-after-free vulnerability in the resolver in nginx 0.6.18 through 1.8.0 and 1.9.x before 1.9.10 allows remote attackers to cause a denial of service (worker process crash) or possibly have unspecified other impact via a crafted DNS response related to CNAME response processing.

    • Update to 1.9.10-1
    Published Updated
  5. CVE-2014-3556

    Not ratedEPSS 7.83%Fix available

    CVE-2014-3556

    The STARTTLS implementation in mail/ngx_mail_smtp_handler.c in the SMTP proxy in nginx 1.5.x and 1.6.x before 1.6.1 and 1.7.x before 1.7.4 does not properly restrict I/O buffering, which allows man-in-the-middle attackers to insert commands into encrypted SMTP sessions by sending a cleartext command that is processed after TLS is in place, related to a "plaintext command injection" attack, a similar issue to CVE-2011-0411.

    • Update to 1.6.1-1
    Published Updated
  6. CVE-2013-2070

    Not ratedEPSS 11.92%Fix available

    CVE-2013-2070

    http/modules/ngx_http_proxy_module.c in nginx 1.1.4 through 1.2.8 and 1.3.0 through 1.4.0, when proxy_pass is used with untrusted HTTP servers, allows remote attackers to cause a denial of service (crash) and obtain sensitive information from worker process memory via a crafted proxy response, a similar vulnerability to CVE-2013-2028.

    • Update to 1.4.1-1
    Published Updated
  7. CVE-2012-4929

    Not ratedEPSS 4.35%Fix available

    CVE-2012-4929

    The TLS protocol 1.2 and earlier, as used in Mozilla Firefox, Google Chrome, Qt, and other products, can encrypt compressed data without properly obfuscating the length of the unencrypted data, which allows man-in-the-middle attackers to obtain plaintext HTTP headers by observing length differences during a series of guesses in which a string in an HTTP request potentially matches an unknown string in an HTTP header, aka a "CRIME" attack.

    • Update to 1.2.1-2.2
    Published Updated
  8. CVE-2012-2089

    Not ratedEPSS 9.78%Fix available

    CVE-2012-2089

    Buffer overflow in ngx_http_mp4_module.c in the ngx_http_mp4_module module in nginx 1.0.7 through 1.0.14 and 1.1.3 through 1.1.18, when the mp4 directive is used, allows remote attackers to cause a denial of service (memory overwrite) or possibly execute arbitrary code via a crafted MP4 file.

    • Update to 1.1.19-1
    Published Updated
  9. CVE-2009-4487

    Not ratedEPSS 29.52%Public exploitNo fix published

    CVE-2009-4487

    nginx 0.7.64 writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →