p PatchFirst

PatchFirst · Latest vulnerabilities

rails vulnerabilities · Page 3

Vulnerabilities published for rails in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 114

  1. CVE-2021-22880

    High · CVSS 7.5EPSS 4.43%Public exploitFix available

    CVE-2021-22880

    The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS) vulnerability. Carefully crafted input can cause the input validation in the `money` type of the PostgreSQL adapter in Active Record to spend too much time in a regular expression, resulting in the potential for a DoS attack. This only impacts Rails applications that are using PostgreSQL along with money type columns that take user input.

    • Update to 2:6.0.3.5+dfsg-1
    Published Updated
  2. CVE-2020-8264

    Medium · CVSS 6.1EPSS 66.99%Fix available

    CVE-2020-8264

    In actionpack gem >= 6.0.0, a possible XSS vulnerability exists when an application is running in development mode allowing an attacker to send or embed (in another page) a specially crafted URL which can allow the attacker to execute JavaScript in the context of the local application. This vulnerability is in the Actionable Exceptions middleware.

    • Update to 2:6.0.3.4+dfsg-1
    Published Updated
  3. CVE-2020-15169

    Medium · CVSS 5.4EPSS 2.37%Fix available

    XSS in Action View

    In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.

    • Update to 2:6.0.3.3+dfsg-1
    Published Updated
  4. CVE-2020-5267

    Medium · CVSS 4EPSS 1.52%Fix available

    Possible XSS vulnerability in ActionView

    In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers. Views that use the `j` or `escape_javascript` methods may be susceptible to XSS attacks. The issue is fixed in versions 6.0.2.2 and 5.2.4.2.

    • Update to 2:5.2.4.1+dfsg-2
    Published Updated
  5. CVE-2019-5420

    Critical · CVSS 9.8EPSS 89.33%Public exploitFix available

    CVE-2019-5420

    A remote code execution vulnerability in development mode Rails <5.2.2.1, <6.0.0.beta3 can allow an attacker to guess the automatically generated development mode secret token. This secret token can be used in combination with other Rails internals to escalate to a remote code execution exploit.

    • Update to 2:5.2.2.1+dfsg-1
    Published Updated
  6. CVE-2018-16477

    Medium · CVSS 6.5EPSS 1.31%Fix available

    CVE-2018-16477

    A bypass vulnerability in Active Storage >= 5.2.0 for Google Cloud Storage and Disk services allow an attacker to modify the `content-disposition` and `content-type` parameters which can be used in with HTML files and have them executed inline. Additionally, if combined with other techniques such as cookie bombing and specially crafted AppCache manifests, an attacker can gain access to private signed URLs within a specific storage path. This vulnerability has been fixed in version 5.2.1.1.

    • Update to 2:5.2.2+dfsg-1
    Published Updated
  7. CVE-2018-16476

    High · CVSS 7.5EPSS 2.86%Fix available

    CVE-2018-16476

    A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.

    • Update to 2:5.2.2+dfsg-1
    Published Updated
  8. CVE-2017-17920

    High · CVSS 8.1EPSS 1.51%No fix published

    CVE-2017-17920

    SQL injection vulnerability in the 'reorder' method in Ruby on Rails 5.1.4 and earlier allows remote attackers to execute arbitrary SQL commands via the 'name' parameter. NOTE: The vendor disputes this issue because the documentation states that this method is not intended for use with untrusted input

    Published Updated
  9. CVE-2017-17919

    High · CVSS 8.1EPSS 1.51%No fix published

    CVE-2017-17919

    SQL injection vulnerability in the 'order' method in Ruby on Rails 5.1.4 and earlier allows remote attackers to execute arbitrary SQL commands via the 'id desc' parameter. NOTE: The vendor disputes this issue because the documentation states that this method is not intended for use with untrusted input

    Published Updated
  10. CVE-2017-17917

    High · CVSS 8.1EPSS 2.28%No fix published

    CVE-2017-17917

    SQL injection vulnerability in the 'where' method in Ruby on Rails 5.1.4 and earlier allows remote attackers to execute arbitrary SQL commands via the 'id' parameter. NOTE: The vendor disputes this issue because the documentation states that this method is not intended for use with untrusted input

    Published Updated
  11. CVE-2017-17916

    High · CVSS 8.1EPSS 1.54%No fix published

    CVE-2017-17916

    SQL injection vulnerability in the 'find_by' method in Ruby on Rails 5.1.4 and earlier allows remote attackers to execute arbitrary SQL commands via the 'name' parameter. NOTE: The vendor disputes this issue because the documentation states that this method is not intended for use with untrusted input

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →