p PatchFirst

PatchFirst · Latest vulnerabilities

rails vulnerabilities · Page 4

Vulnerabilities published for rails in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 114

  1. CVE-2016-6317

    High · CVSS 7.5EPSS 3.9%Fix available

    CVE-2016-6317

    Action Record in Ruby on Rails 4.2.x before 4.2.7.1 does not properly consider differences in parameter handling between the Active Record component and the JSON implementation, which allows remote attackers to bypass intended database-query restrictions and perform NULL checks or trigger missing WHERE clauses via a crafted request, as demonstrated by certain "[nil]" values, a related issue to CVE-2012-2660, CVE-2012-2694, and CVE-2013-0155.

    • Update to 2:4.2.7.1-1
    Published Updated
  2. CVE-2016-6316

    Medium · CVSS 6.1EPSS 3.44%Fix available

    CVE-2016-6316

    Cross-site scripting (XSS) vulnerability in Action View in Ruby on Rails 3.x before 3.2.22.3, 4.x before 4.2.7.1, and 5.x before 5.0.0.1 might allow remote attackers to inject arbitrary web script or HTML via text declared as "HTML safe" and used as attribute values in tag handlers.

    • Update to 2:4.2.7.1-1
    Published Updated
  3. CVE-2016-2097

    Medium · CVSS 5.3EPSS 4.42%Fix available

    CVE-2016-2097

    Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.2 and 4.x before 4.1.14.2 allows remote attackers to read arbitrary files by leveraging an application's unrestricted use of the render method and providing a .. (dot dot) in a pathname. NOTE: this vulnerability exists because of an incomplete fix for CVE-2016-0752.

    • Update to 2:4.2.5.2-1
    Published Updated
  4. CVE-2016-0752

    High · CVSS 7.5EPSS 95.54%In KEVPublic exploitFix available

    CVE-2016-0752

    Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 allows remote attackers to read arbitrary files by leveraging an application's unrestricted use of the render method and providing a .. (dot dot) in a pathname.

    • Update to 2:4.2.5.1-1
    Published Updated
  5. CVE-2016-0751

    High · CVSS 7.5EPSS 9.73%Fix available

    CVE-2016-0751

    actionpack/lib/action_dispatch/http/mime_type.rb in Action Pack in Ruby on Rails before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 does not properly restrict use of the MIME type cache, which allows remote attackers to cause a denial of service (memory consumption) via a crafted HTTP Accept header.

    • Update to 2:4.2.5.1-1
    Published Updated
  6. CVE-2015-7581

    High · CVSS 7.5EPSS 6.71%Fix available

    CVE-2015-7581

    actionpack/lib/action_dispatch/routing/route_set.rb in Action Pack in Ruby on Rails 4.x before 4.2.5.1 and 5.x before 5.0.0.beta1.1 allows remote attackers to cause a denial of service (superfluous caching and memory consumption) by leveraging an application's use of a wildcard controller route.

    • Update to 2:4.2.5.1-1
    Published Updated
  7. CVE-2015-7577

    Medium · CVSS 5.3EPSS 4.25%Fix available

    CVE-2015-7577

    activerecord/lib/active_record/nested_attributes.rb in Active Record in Ruby on Rails 3.1.x and 3.2.x before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 does not properly implement a certain destroy option, which allows remote attackers to bypass intended change restrictions by leveraging use of the nested attributes feature.

    • Update to 2:4.2.5.1-1
    Published Updated
  8. CVE-2015-7576

    Low · CVSS 3.7EPSS 4.88%Fix available

    CVE-2015-7576

    The http_basic_authenticate_with method in actionpack/lib/action_controller/metal/http_authentication.rb in the Basic Authentication implementation in Action Controller in Ruby on Rails before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 does not use a constant-time algorithm for verifying credentials, which makes it easier for remote attackers to bypass authentication by measuring timing differences.

    • Update to 2:4.2.5.1-1
    Published Updated
  9. CVE-2014-7829

    Not ratedEPSS 4.16%Fix available

    CVE-2014-7829

    Directory traversal vulnerability in actionpack/lib/action_dispatch/middleware/static.rb in Action Pack in Ruby on Rails 3.x before 3.2.21, 4.0.x before 4.0.12, 4.1.x before 4.1.8, and 4.2.x before 4.2.0.beta4, when serve_static_assets is enabled, allows remote attackers to determine the existence of files outside the application root via vectors involving a \ (backslash) character, a similar issue to CVE-2014-7818.

    • Update to 2:4.1.8-1
    Published Updated
  10. CVE-2014-7818

    Not ratedEPSS 3.46%Fix available

    CVE-2014-7818

    Directory traversal vulnerability in actionpack/lib/action_dispatch/middleware/static.rb in Action Pack in Ruby on Rails 3.x before 3.2.20, 4.0.x before 4.0.11, 4.1.x before 4.1.7, and 4.2.x before 4.2.0.beta3, when serve_static_assets is enabled, allows remote attackers to determine the existence of files outside the application root via a /..%2F sequence.

    • Update to 2:4.1.8-1
    Published Updated
  11. CVE-2014-3483

    Not ratedEPSS 4.18%Fix available

    CVE-2014-3483

    SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/quoting.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 4.x before 4.0.7 and 4.1.x before 4.1.3 allows remote attackers to execute arbitrary SQL commands by leveraging improper range quoting.

    • Update to 2:4.1.4-1
    Published Updated
  12. CVE-2014-3482

    Not ratedEPSS 4.28%Fix available

    CVE-2014-3482

    SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 2.x and 3.x before 3.2.19 allows remote attackers to execute arbitrary SQL commands by leveraging improper bitstring quoting.

    • Update to 2:4.1.4-1
    Published Updated
  13. CVE-2014-0082

    Not ratedEPSS 6.19%Fix available

    CVE-2014-0082

    actionpack/lib/action_view/template/text.rb in Action View in Ruby on Rails 3.x before 3.2.17 converts MIME type strings to symbols during use of the :text option to the render method, which allows remote attackers to cause a denial of service (memory consumption) by including these strings in headers.

    • Update to 2.3.14.1
    Published Updated
  14. CVE-2014-0081

    Not ratedEPSS 4.03%Fix available

    CVE-2014-0081

    Multiple cross-site scripting (XSS) vulnerabilities in actionview/lib/action_view/helpers/number_helper.rb in Ruby on Rails before 3.2.17, 4.0.x before 4.0.3, and 4.1.x before 4.1.0.beta2 allow remote attackers to inject arbitrary web script or HTML via the (1) format, (2) negative_format, or (3) units parameter to the (a) number_to_currency, (b) number_to_percentage, or (c) number_to_human helper.

    • Update to 2.3.14.1
    Published Updated
  15. CVE-2013-3221

    Not ratedEPSS 2.4%Fix available

    CVE-2013-3221

    The Active Record component in Ruby on Rails 2.3.x, 3.0.x, 3.1.x, and 3.2.x does not ensure that the declared data type of a database column is used during comparisons of input values to stored values in that column, which makes it easier for remote attackers to conduct data-type injection attacks against Ruby on Rails applications via a crafted value, as demonstrated by unintended interaction between the "typed XML" feature and a MySQL database.

    • Update to 2.3.14.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →