p PatchFirst

PatchFirst · Latest vulnerabilities

xpdf vulnerabilities · Page 2

Vulnerabilities published for xpdf in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 77

  1. CVE-2011-1554

    Not ratedEPSS 5.42%Fix available

    CVE-2011-1554

    Off-by-one error in t1lib 5.1.2 and earlier, as used in Xpdf before 3.02pl6, teTeX, and other products, allows remote attackers to cause a denial of service (application crash) via a PDF document containing a crafted Type 1 font that triggers an invalid memory read, integer overflow, and invalid pointer dereference, a different vulnerability than CVE-2011-0764.

    • Update to 3.02-9
    Published Updated
  2. CVE-2011-1553

    Not ratedEPSS 5.42%Fix available

    CVE-2011-1553

    Use-after-free vulnerability in t1lib 5.1.2 and earlier, as used in Xpdf before 3.02pl6, teTeX, and other products, allows remote attackers to cause a denial of service (application crash) via a PDF document containing a crafted Type 1 font that triggers an invalid memory write, a different vulnerability than CVE-2011-0764.

    • Update to 3.02-9
    Published Updated
  3. CVE-2011-1552

    Not ratedEPSS 10.38%Fix available

    CVE-2011-1552

    t1lib 5.1.2 and earlier, as used in Xpdf before 3.02pl6, teTeX, and other products, reads from invalid memory locations, which allows remote attackers to cause a denial of service (application crash) via a crafted Type 1 font in a PDF document, a different vulnerability than CVE-2011-0764.

    • Update to 3.02-9
    Published Updated
  4. CVE-2011-0764

    Not ratedEPSS 13.05%Fix available

    CVE-2011-0764

    t1lib 5.1.2 and earlier, as used in Xpdf before 3.02pl6, teTeX, and other products, uses an invalid pointer in conjunction with a dereference operation, which allows remote attackers to execute arbitrary code via a crafted Type 1 font in a PDF document, as demonstrated by testz.2184122398.pdf.

    • Update to 3.02-9
    Published Updated
  5. CVE-2010-3704

    Not ratedEPSS 3.6%Fix available

    CVE-2010-3704

    The FoFiType1::parse function in fofi/FoFiType1.cc in the PDF parser in xpdf before 3.02pl5, poppler 0.8.7 and possibly other versions up to 0.15.1, kdegraphics, and possibly other products allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a PDF file with a crafted PostScript Type1 font that contains a negative array index, which bypasses input validation and triggers memory corruption.

    • Update to 3.02-9
    Published Updated
  6. CVE-2010-3703

    Not ratedEPSS 2.56%Fix available

    CVE-2010-3703

    The PostScriptFunction::PostScriptFunction function in poppler/Function.cc in the PDF parser in poppler 0.8.7 and possibly other versions up to 0.15.1, and possibly other products, allows context-dependent attackers to cause a denial of service (crash) via a PDF file that triggers an uninitialized pointer dereference.

    • Update to 3.02-9
    Published Updated
  7. CVE-2010-3702

    Not ratedEPSS 2.76%Fix available

    CVE-2010-3702

    The Gfx::getPos function in the PDF parser in xpdf before 3.02pl5, poppler 0.8.7 and possibly other versions up to 0.15.1, CUPS, kdegraphics, and possibly other products allows context-dependent attackers to cause a denial of service (crash) via unknown vectors that trigger an uninitialized pointer dereference.

    • Update to 3.02-9
    Published Updated
  8. CVE-2009-4035

    Not ratedEPSS 3.79%Fix available

    CVE-2009-4035

    The FoFiType1::parse function in fofi/FoFiType1.cc in Xpdf 3.0.0, gpdf 2.8.2, kpdf in kdegraphics 3.3.1, and possibly other libraries and versions, does not check the return value of the getNextLine function, which allows context-dependent attackers to execute arbitrary code via a PDF file with a crafted Type 1 font that can produce a negative value, leading to a signed-to-unsigned integer conversion error and a buffer overflow.

    • Update to 3.01-1
    Published Updated
  9. CVE-2009-3609

    Not ratedEPSS 4.67%Fix available

    CVE-2009-3609

    Integer overflow in the ImageStream::ImageStream function in Stream.cc in Xpdf before 3.02pl4 and Poppler before 0.12.1, as used in GPdf, kdegraphics KPDF, and CUPS pdftops, allows remote attackers to cause a denial of service (application crash) via a crafted PDF document that triggers a NULL pointer dereference or buffer over-read.

    • Update to 3.02-2
    Published Updated
  10. CVE-2009-3608

    Not ratedEPSS 10.23%Fix available

    CVE-2009-3608

    Integer overflow in the ObjectStream::ObjectStream function in XRef.cc in Xpdf 3.x before 3.02pl4 and Poppler before 0.12.1, as used in GPdf, kdegraphics KPDF, CUPS pdftops, and teTeX, might allow remote attackers to execute arbitrary code via a crafted PDF document that triggers a heap-based buffer overflow.

    • Update to 3.02-2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →